summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/plumbum
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest6
-rw-r--r--dev-python/plumbum/files/plumbum-1.6.4.patch35
-rw-r--r--dev-python/plumbum/metadata.xml20
-rw-r--r--dev-python/plumbum/plumbum-1.6.0.ebuild14
-rw-r--r--dev-python/plumbum/plumbum-1.6.4.ebuild17
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
new file mode 100644
index 000000000000..ec7b31de032e
--- /dev/null
+++ b/dev-python/plumbum/Manifest
@@ -0,0 +1,6 @@
+AUX plumbum-1.6.4.patch 1521 BLAKE2B f65f963fbba8f8e585b8bcaa99f3cc377f485867994294d0116380d61d05fa0ff509f2df07e869fc12fb817d8c0ae3c97c9c71cc65b3e028eff708ac82565b09 SHA512 cd054cd97f055c571b627bdb54b4644dca4653f06efd9022a74cbd632486f1fe3cec65969168895aba85bed4bb0e060bbaf11009d31d21d9537dca5b4f29a539
+DIST plumbum-1.6.0.tar.gz 77092 BLAKE2B 795101098614dfe547e884fb3c4f9e7947a65995a5223d89a83aedd91ed7d4eac25dd926d022e32384430620561128f9e957d05af68c463a65b58e8a86ce2717 SHA512 0be9461720cb03c56aff8f56705b1753013e02df4b4d3dbc7e8379930b9efb3822df587483ca708f3a16f08d625f03459f8fe377bc50e59439d05f73669003cc
+DIST plumbum-1.6.4.tar.gz 88041 BLAKE2B aadd929fc6878bd49ac3169b1b4235140d08ff452eb5eb61e43f9ad869ea867916d76ee7f2befb68e67cdd9d9b19c364d6e02810866f6ba5022cf7064d240786 SHA512 26110741251d75ae9b47f522aba38e8af7a658d22900b1487b3f6e4e6971e4682283003e674f40345e14dd4103f6d485fc569348cc1245ac0440cd04688abe99
+EBUILD plumbum-1.6.0.ebuild 401 BLAKE2B 3d75d35fa45b284dc076a2658210b70eaedbb8ca8bf1b4bff635a5efd97f91dd3fd6dddd2d255c49fd1d63a59efead5a66dde4dde484bb3c079cca9ed1c59b38 SHA512 e7516ced1b546c0353a265c6726ab5602e598c95eca1e1327d8a5d82b0db8de73217fcaf41b00d829ad1ff15c41741ce216066471c6b4057b1024a18027e99ac
+EBUILD plumbum-1.6.4.ebuild 498 BLAKE2B fc648f18bdd2919185b6cd3f4e7f91f5f43bf9e36fcfff07b7fb8ee9e65b50bd64ea21715896f1f454d680949abda63a2dc06d984b438efb1485f132ae51f573 SHA512 60c8398f8171411cfb4a583c0724d12184c140069a357eb58faf4d97ad024476cc2546efa753aefff1ead95dfee750f99b0c5ca92d4bf34a2192256600922b5f
+MISC metadata.xml 667 BLAKE2B 831314c0a117c620e7d17f7023d0bed99deba80cf0d84852bd972ca788aa8e4ed6d959938fe5c7592db95b13d600a86b7928aa46a58d65cf1b9e48a2209b5c61 SHA512 c44ac643857f1e096d33e7ac3ae9a5a7e135861b7f6e26a3b889d9cc4fd5d302ac9657520c73cdc618b95ee31f168cb2e5704c1bf1b7710b859e57a2abafa812
diff --git a/dev-python/plumbum/files/plumbum-1.6.4.patch b/dev-python/plumbum/files/plumbum-1.6.4.patch
new file mode 100644
index 000000000000..ce18d7afe09d
--- /dev/null
+++ b/dev-python/plumbum/files/plumbum-1.6.4.patch
@@ -0,0 +1,35 @@
+diff -r -U2 plumbum-1.6.4.orig/plumbum/cli/image.py plumbum-1.6.4/plumbum/cli/image.py
+--- plumbum-1.6.4.orig/plumbum/cli/image.py 2017-11-08 21:20:49.000000000 +0700
++++ plumbum-1.6.4/plumbum/cli/image.py 2017-12-15 15:45:16.184943092 +0700
+@@ -3,5 +3,6 @@
+ from plumbum import colors
+ from .termsize import get_terminal_size
+-import . as cli
++from .application import Application
++from .switches import switch, SwitchAttr, Flag, positional, Range, ExistingFile
+ import sys
+
+@@ -75,17 +76,17 @@
+ print(colors.reset)
+
+-class ShowImageApp(cli.Application):
++class ShowImageApp(Application):
+ 'Display an image on the terminal'
+- double = cli.Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
++ double = Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
+
+- @cli.switch(['-c','--colors'], cli.Range(1,4), help="Level of color, 1-4")
++ @switch(['-c','--colors'], Range(1,4), help="Level of color, 1-4")
+ def colors_set(self, n):
+ colors.use_color = n
+
+- size = cli.SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
++ size = SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
+
+- ratio = cli.SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
++ ratio = SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
+
+- @cli.positional(cli.ExistingFile)
++ @positional(ExistingFile)
+ def main(self, filename):
+
diff --git a/dev-python/plumbum/metadata.xml b/dev-python/plumbum/metadata.xml
new file mode 100644
index 000000000000..a442e52d0d35
--- /dev/null
+++ b/dev-python/plumbum/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A library for shell script-like programs in python,
+ attempting to mimic the shell syntax (shell combinators) where it makes sense,
+ while keeping it all Pythonic and cross-platform.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">plumbum</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/plumbum/plumbum-1.6.0.ebuild b/dev-python/plumbum/plumbum-1.6.0.ebuild
new file mode 100644
index 000000000000..dc3714d61357
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.6.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
diff --git a/dev-python/plumbum/plumbum-1.6.4.ebuild b/dev-python/plumbum/plumbum-1.6.4.ebuild
new file mode 100644
index 000000000000..5db056d4549d
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.6.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+PATCHES=( "${FILESDIR}"/${P}.patch )