summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/plumbum
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest2
-rw-r--r--dev-python/plumbum/plumbum-1.7.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 690bba8aeb2e..1bf9d3cd8c2c 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,3 +1,5 @@
DIST plumbum-1.7.0.tar.gz 318890 BLAKE2B 19ae8a37dff38ac3d263d9400e44ac174c46ff8cef92cf45b9ea31d6d344543fba66de3fd0fcd15acc205af5939f11be6c56e6cd9ca39a666f92f18dcd29b9f7 SHA512 0a12891278c12bb98b8bbb825448375240ee347eb3ca166b9cbb4da3e083979d947a7bf0a843fd9a0b7c9a13d09f24e988ee877f29420a3f29f40e387eec8826
+DIST plumbum-1.7.1.tar.gz 323014 BLAKE2B 28d9616c3bcb13f1e9cf9c47b4533c62caf630d7eab998e86023256b568f8f038444f8741bb902ed999f04f480bc09159aab075d184f497b00a452bfac57c996 SHA512 d6648acce8e84045cd8c2fc4a90c427fd5ab5a39e49e7a1f10b20ffbca20cc42636183325501e5b577631e4f1c5a1b3e7cae12ec6b89ff853e5a50946c15f3c7
EBUILD plumbum-1.7.0-r1.ebuild 1339 BLAKE2B 5d257b5e20813428799747fab22f7778e319db1f377db8ca7dea92dc640a5ba52503e9d98941b15bb3ddbcbad1e0349145a4e0832817234d13d43eb7dd4786d9 SHA512 565c0ef4252bc782a074fec930256519bdea3e088a64c3b4afb6326e35bdebeae724a0287b5568461a0d1cbf008f7148a6a4508c2f54117da7eadf5f43c46635
+EBUILD plumbum-1.7.1.ebuild 1317 BLAKE2B cafd29a93571c3e4a866cdd1c65098d022a4339f1f7055184aaa0613561cc6901a4fa1df5d94c02f61696cf4ec5a8516c4ae2a148e79ab871d989562e8c93a75 SHA512 4bd827edf5ece4b83b1801de4df8998e3b44c06b84751aecb8e3cb44ea3b7e421950679f9893a408222ef8f28e0c9f2e06275fe51626bfcf0b76db922ae0ed28
MISC metadata.xml 754 BLAKE2B b6d00fe0747da15445953a29abdd6f14112d02f2162746992f2fca80a321cd10f3cad40294e4bdbcf3f04d432b4d81902667296a0a5b8f99da2df2a5c58b18c1 SHA512 fbadbb7e5edd1573994cfc843e4a254ae5d12be5a3372f4fb061647983e360c2b0ea4a9e41ea8c9ff26028db75ad9cd5de881b8fdd9bf35864442e215aa42175
diff --git a/dev-python/plumbum/plumbum-1.7.1.ebuild b/dev-python/plumbum/plumbum-1.7.1.ebuild
new file mode 100644
index 000000000000..1102887095ff
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+)
+
+src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}