summaryrefslogtreecommitdiff
path: root/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /dev-python/plumbum/plumbum-1.7.0-r1.ebuild
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'dev-python/plumbum/plumbum-1.7.0-r1.ebuild')
-rw-r--r--dev-python/plumbum/plumbum-1.7.0-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
deleted file mode 100644
index 09603ad72375..000000000000
--- a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A library for shell script-like programs in python"
-HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-BDEPEND="
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e '/addopts/d' -i setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # Need sshd running
- tests/test_remote.py
- tests/test_utils.py
- # Windows specific
- tests/test_putty.py
- # Needs sudo without password
- tests/test_sudo.py
- # Wrong assumptions about env handling
- tests/test_env.py::TestEnv::test_change_env
- tests/test_env.py::TestEnv::test_dictlike
- tests/test_local.py::TestLocalPath::test_iterdir
- )
- epytest ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "remote commands via ssh" dev-python/paramiko
- optfeature "progress bars in jupyter" dev-python/ipywidgets
- optfeature "colored output in jupyter" dev-python/ipython
- optfeature "images on the command line" dev-python/pillow
-}