summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pluginbase
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/Manifest3
-rw-r--r--dev-python/pluginbase/metadata.xml12
-rw-r--r--dev-python/pluginbase/pluginbase-0.5.ebuild41
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
new file mode 100644
index 000000000000..8cfcc36b3ea2
--- /dev/null
+++ b/dev-python/pluginbase/Manifest
@@ -0,0 +1,3 @@
+DIST pluginbase-0.5.tar.gz 41964 SHA256 b4f830242a078a4f44c978a84f3365bba4d008fdd71a591c71447f4df35354dd SHA512 921ddc7dacb6ad63abc90beb1d1d993e7b15c9cfe21e850a5852eb40735436e08b39fd2a6d83e23f641014ee81e718aca147ef1e21b55f94ce04a64ba7780455 WHIRLPOOL c15e58b029c101aea683df671fd7e58bcfa8635a21ca0a5867ac04114b1b9855a1ba4eac590231b408ac69c0f9bf4ef3c0bb3248797e762550af5e6403bf9593
+EBUILD pluginbase-0.5.ebuild 917 SHA256 f126d34af2aa548d92ead53693c60f168440c0c6380d1ef4e62ad6bec2ba96bf SHA512 067e39436d41b0e5c713385560957ed4ec4e393d7e2428e9a7d39fd168e2cdda8dd1b7811b149ee3af299eb50cc21d1826fa733fc160f51027e73a2e89ce7b5f WHIRLPOOL d1596270337d7a9b22893ac356f793fe228c66bbbddbf01e37ae84b7e34cca68901070f5d9e86b5d3654913d52733e24278a5c1abfebd067a63fc2f3fcc172fb
+MISC metadata.xml 385 SHA256 6bc3a367d523c7f6b7c762902fcfe6027aef372b8069ddd09c941d92cf5b0c0c SHA512 166cec1bf4ad16e00b937dca860dedef5f8f766c1e3edae03dd29753ad9590843601723243e702344d1d4853b4d1a87c9c0960f9b70ac3dd4ad40995333516b2 WHIRLPOOL b92a802bd0a41c7d31497d914fa0a1847759bd82b7a332f7dea04eb245a96780bf507ac220739b0fec44f5d60186c88ea7dc5a8e7e133e65cd417e220b7c96fe
diff --git a/dev-python/pluginbase/metadata.xml b/dev-python/pluginbase/metadata.xml
new file mode 100644
index 000000000000..0610970f98a5
--- /dev/null
+++ b/dev-python/pluginbase/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pluginbase</remote-id>
+ <remote-id type="github">mitsuhijo/pluginbase</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pluginbase/pluginbase-0.5.ebuild b/dev-python/pluginbase/pluginbase-0.5.ebuild
new file mode 100644
index 000000000000..8954509650f8
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -e "s/, 'sphinx.ext.intersphinx'//" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ cd tests && PYTHONPATH=.. py.test --tb=native || die "Tests fail with ${EPYTHON}"
+}