summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pluginbase
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/Manifest3
-rw-r--r--dev-python/pluginbase/metadata.xml12
-rw-r--r--dev-python/pluginbase/pluginbase-0.5.ebuild41
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
deleted file mode 100644
index 0c87bd2dfef6..000000000000
--- a/dev-python/pluginbase/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pluginbase-0.5.tar.gz 41964 BLAKE2B 84fc187b60182f100a9016ac663856b29587e60b5ef5ac9c51fb4ed99666908a77c9817c2dc5fb64e82b807e635bd10beb5ce7644e31e63262736cc667a7b8c2 SHA512 921ddc7dacb6ad63abc90beb1d1d993e7b15c9cfe21e850a5852eb40735436e08b39fd2a6d83e23f641014ee81e718aca147ef1e21b55f94ce04a64ba7780455
-EBUILD pluginbase-0.5.ebuild 917 BLAKE2B fd95dcfc5a93fe72eed31091eed98d5676993fa39c561baa73f9e0528b65ec6a5b69edd4454589bdd09aa7dce701ff8fdb345ff477075765ecb24098d2b16ef2 SHA512 067e39436d41b0e5c713385560957ed4ec4e393d7e2428e9a7d39fd168e2cdda8dd1b7811b149ee3af299eb50cc21d1826fa733fc160f51027e73a2e89ce7b5f
-MISC metadata.xml 385 BLAKE2B 0b58f71f7f6e816ba3b2c41212f371d37b0b09b38fc69a1adcdbab7a4537f9e9e7c5c0d9505e5dc72d219f30aeb5a3739c7f58bf4927f75323bd2b34e25733dd SHA512 166cec1bf4ad16e00b937dca860dedef5f8f766c1e3edae03dd29753ad9590843601723243e702344d1d4853b4d1a87c9c0960f9b70ac3dd4ad40995333516b2
diff --git a/dev-python/pluginbase/metadata.xml b/dev-python/pluginbase/metadata.xml
deleted file mode 100644
index 0610970f98a5..000000000000
--- a/dev-python/pluginbase/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pluginbase</remote-id>
- <remote-id type="github">mitsuhijo/pluginbase</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pluginbase/pluginbase-0.5.ebuild b/dev-python/pluginbase/pluginbase-0.5.ebuild
deleted file mode 100644
index 8954509650f8..000000000000
--- a/dev-python/pluginbase/pluginbase-0.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Support library for building plugins sytems in Python"
-HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- sed -e "s/, 'sphinx.ext.intersphinx'//" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- cd tests && PYTHONPATH=.. py.test --tb=native || die "Tests fail with ${EPYTHON}"
-}