summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
commit063e5b486db858a2b1ecec798af89f5484d475bd (patch)
tree490932df05aadb9cbb3611e63a31507953ab5c91 /dev-python/pluginbase
parenta0953f7ac639d8e180f62ab3364ccf9af71f783d (diff)
gentoo auto-resync : 27:02:2023 - 03:59:17
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/Manifest3
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild24
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1.ebuild2
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
index f8eac44ef92b..a12fab14edc3 100644
--- a/dev-python/pluginbase/Manifest
+++ b/dev-python/pluginbase/Manifest
@@ -1,3 +1,4 @@
DIST pluginbase-1.0.1.tar.gz 43588 BLAKE2B 8d72dc0afcf4e4e65670902bd3f28a1a36de7f7cc11fd56c624f871ced39e8b989bc6ac74d64e4f96b3bf32f0f4e187ae8b517f9a09cac94b7a735ffb08ec55b SHA512 20844fb78daf3e03a7a8013f82a059bf6b0723a184e89061ce5cb674b5a978900623f2eceed56fc9f9a34410e7e6ca8d41a5ac0a21e374b1b3ce32d4e522348e
-EBUILD pluginbase-1.0.1.ebuild 504 BLAKE2B a623fdbac61f442d9cded31904e2e0d90934be717d05ba33b3e50da45fe78fa73eaf02bf4e8b3ec6bc3539158728cd1391ef3177bd5f8c1e26b8fbe0e4050608 SHA512 3062872b746eea1ff0ce9f5e7bb4b449bda8bccb5b4e8272c57c53ff339d8f15da489eea55f64ee7f862ecf5afc8e0012510cb6191dc3827be7cee182bb48550
+EBUILD pluginbase-1.0.1-r1.ebuild 489 BLAKE2B 82127c0c3494467bc1833c2c61d9a2f465515d76d63fb0ea9cd2dbdb1848a8f1fa2ee7041d8c8e36bb437729aa4e80e247287f741eddd924678f73303cd1cf71 SHA512 b9af161f0c27794061c624f0759879f0a72273cfbccca3e1831ccf2a8016211e1f56eeedc8854efb48a84579a86a579321b933a29d8f32a54cbeb781ad3ce371
+EBUILD pluginbase-1.0.1.ebuild 504 BLAKE2B 79696d8b109a356cfa97b48e8186ed63d4fb68c380a7ca84a33bf79ab2a4133151bef5b5bbb6688f34039c9a5b76efe45b55a9f423ebfbbe933805b1789c0fdf SHA512 90e310bffaccef9b514a93e5347085ef381cdb2065bbe0ed8c4be5e9e2a8e5bf7f698d2d704719057e9691dc63fe6b3b95d40cc751e447b8d95d2cf18a72bb19
MISC metadata.xml 374 BLAKE2B 2cbfa086bf9a21226b2d2f1ad29c80c32a99ab8f1519badca3cafb2255e307096d07df1d39ce12db888301e5c336b908cc680b80f8b00f43a7bcee0f783106a5 SHA512 bb83860ccf6e9d30d86d7406b89fa56f121e7b466164a476c802060a8f6bb63898fcfb3b22253ea2700cc99095f6754745d67fb2a611792802cba20179698051
diff --git a/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7b3d8dd18f94
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/pluginbase/pluginbase-1.0.1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
index c29ca3b56bd5..09171d3d95c2 100644
--- a/dev-python/pluginbase/pluginbase-1.0.1.ebuild
+++ b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1