summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase/pluginbase-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/pluginbase/pluginbase-1.0.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/pluginbase/pluginbase-1.0.1.ebuild')
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pluginbase/pluginbase-1.0.1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
new file mode 100644
index 000000000000..b0a0602f7938
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}