summaryrefslogtreecommitdiff
path: root/dev-python/pluggy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 19:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 19:19:56 +0100
commitc0bcbed1a8a833beeae3ab7541dc9f460ab7cfce (patch)
treecfbec5f5e8ea4ab52c4d7bc2966c1ab960fe64ba /dev-python/pluggy
parentb02a2ac044a27eeef2c52b57308a8591b07448fa (diff)
gentoo auto-resync : 21:06:2023 - 19:19:56
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest2
-rw-r--r--dev-python/pluggy/pluggy-1.2.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index e5e5a4e30f13..aea4e5467e3f 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1,5 +1,7 @@
DIST pluggy-1.0.0.tar.gz 51510 BLAKE2B 8107df9a91a843166a602e7518dd1d4167304464a8cc80180b60b03a2ac803be9b1ba190df9189907addd34a92b93a6b271d3d6b7485aa563203ce733c6a656c SHA512 cf0bcbb4330c24ce473614befa19548f33fb39fa0ad094e1eae786202d7adadc28e16499f80ab96b630091765404ca5c5b6f9a55bc605e03514d8ab50cf9ae00
DIST pluggy-1.1.0.tar.gz 59984 BLAKE2B 58dacd5b11e7817f1f4923bcaaa8739c46972b9937b865660d6ae85019582fc9d596b5ab113884925ebb566756aeccd698e2c910a50238e81eda2f413686b8e3 SHA512 3cf95fd78f53525bccf04bc6dfc5101f942bdc3e787ea7c9369c6b2198e014c661999dd64ccce729787d080f44885720e25edd78bac0b93054450e09ff00b7d7
+DIST pluggy-1.2.0.tar.gz 61613 BLAKE2B f1c9d7ca593cd3eaae2f035c8e2d2da09b179991a134e0c0be17642940a853194124b638e208c32b7f8e5250d30d138f4bb79cb414573c0103e6b5024f52abc9 SHA512 b2b6a80737c06e1507eb12513ed7f5ce508fd4a139c559a3a15d9f173f4455ef3847783efb91c32eca6e26cbe37b0336467d50c5db0563d8dbd17bd825cd7407
EBUILD pluggy-1.0.0-r2.ebuild 674 BLAKE2B 89b0af4ba9c26d2939aaedb99af9dc090cdb131029e604e10984c359a27b09905766d102c0592d8cb9f50c90f2b3186cbb353644510b8fac04aebf05a02e4d76 SHA512 8753fbc9681071a4403546b4bc8047df53d91d3ff12479ad354fc07e221c0f09060998fd248da4f1046684f18f00c371da0d50a15819d114a82031ee5e425522
EBUILD pluggy-1.1.0.ebuild 682 BLAKE2B 5bc15ec81ba1959c8d14b46d9fa1a75fafe345a640f2a15c4681c4373bf061bece09d48bd9d5e7faa9f117cb1beb3e210c28bd31e5056e87ede31c4f166e3588 SHA512 c919d981baa92100d7d07974426b4b9b0b2d90113fd653e1a9169c4d4311f6e9d4b62bf9b538325a1da97d5119ac598673a563ee555b29e5fe2b2572a616ee9c
+EBUILD pluggy-1.2.0.ebuild 682 BLAKE2B 5bc15ec81ba1959c8d14b46d9fa1a75fafe345a640f2a15c4681c4373bf061bece09d48bd9d5e7faa9f117cb1beb3e210c28bd31e5056e87ede31c4f166e3588 SHA512 c919d981baa92100d7d07974426b4b9b0b2d90113fd653e1a9169c4d4311f6e9d4b62bf9b538325a1da97d5119ac598673a563ee555b29e5fe2b2572a616ee9c
MISC metadata.xml 506 BLAKE2B cdc1c868281f0140baf75a407eeea26276d7b8f8f0bcafee6393fa144fc054ecf58a812b055d7b48b7d5ab4aa5bc504d6dc567acf4336bb363c9854292d9926b SHA512 5fc4f019e2a518c815662db23bc44920558193cf639c093ec365ba120c113929bcbd9b611d6b2cb7e6057c0bd9d50dc5d1479840a6d379c4610b3ac8aa3ea1d3
diff --git a/dev-python/pluggy/pluggy-1.2.0.ebuild b/dev-python/pluggy/pluggy-1.2.0.ebuild
new file mode 100644
index 000000000000..dd354f8f296d
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest