summaryrefslogtreecommitdiff
path: root/dev-python/pluggy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/pluggy
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest4
-rw-r--r--dev-python/pluggy/pluggy-0.5.2.ebuild4
-rw-r--r--dev-python/pluggy/pluggy-0.6.0.ebuild28
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index be985a97b327..dd6fb8d30ccb 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1,3 +1,5 @@
DIST pluggy-0.5.2.tar.gz 18935 BLAKE2B 8e5bbab9ed0c78a0c6da076ad03618e66780f9ff209f4d08223e7a381eb4d7573727793f4543799e0e557991d4edcdbfd22c0565b69814379806912a4631abf3 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb
-EBUILD pluggy-0.5.2.ebuild 731 BLAKE2B 726af92659ca57937c19bf51e4fc7c11d9c191c06cb991f01139c431767026dd6866400ab75e949f2c1f615a3e7176879174bd2b960db87d5516679396e97f88 SHA512 b82d63bbc78879f45cbc60e59f56a8194afcc2ed99f90e7565c6bff06a3e8ba6993f5f558e9396cb383fc1e0bd32e540aa0194276fc53977bc273f5a8fe47afd
+DIST pluggy-0.6.0.tar.gz 19678 BLAKE2B 79db59c5f0ce0dd157630d039ec50643f615789b6b993d84e9ab1bdc9ce04b32df336d88df13f13a16a1f0bd4acb7b900208e98c84f007bdc3654f9a1d5f19a2 SHA512 dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812
+EBUILD pluggy-0.5.2.ebuild 743 BLAKE2B 6853f04bdf1f049b27c239d54e0244ee061adb80c4d5aa143902c7b977952989b75a17ab296cee689bf8707347cd9a17db29ca8926fe2d4d2004940a264ca8d1 SHA512 31705731d61f327e43831b32c17d46d0c3423959fa4ed102ad0e19d24f7cb1ee4efb195acea3f79b26ffd330adc657e4ad09fc63d4194c294aa6c8a5c7ad3a6f
+EBUILD pluggy-0.6.0.ebuild 753 BLAKE2B 8b4352346cdf3f364a7cb04f3bca7e7b0d364f342f5f92663867ce0d5ab1151fdcb13bbe08f946175ad063b47d0be4a668a7a855daf5dc5c218aa5428403cf5c SHA512 147ce07d6c53e546093fededfbc3bc01ea5de9f11897583e5711f36f4db53713bee4470254b2ad32a5ffd4604dfc28dbd1a2a8e6fead6ff70512bea7bd6a331c
MISC metadata.xml 444 BLAKE2B 9b0b62a0670449bdfade395d9766e192088182f724deebd2a2ace8800ac5c0ff6f37da7174186434f727aa3bee08b9416e6dafae443cd01e01baaae741c899cb SHA512 2ecb5fb612627c44f3499080fcde9241daf2f25a974a8e24fe8190b7d5f8baa6a457b7a902e788f98fe9ed1fdb2cd0f46770337e8f836e430b0aa6f0d323ad50
diff --git a/dev-python/pluggy/pluggy-0.5.2.ebuild b/dev-python/pluggy/pluggy-0.5.2.ebuild
index b92bc377267f..03196120f2fe 100644
--- a/dev-python/pluggy/pluggy-0.5.2.ebuild
+++ b/dev-python/pluggy/pluggy-0.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND=""
diff --git a/dev-python/pluggy/pluggy-0.6.0.ebuild b/dev-python/pluggy/pluggy-0.6.0.ebuild
new file mode 100644
index 000000000000..09df42b74198
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}