summaryrefslogtreecommitdiff
path: root/dev-python/pluggy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pluggy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest5
-rw-r--r--dev-python/pluggy/metadata.xml15
-rw-r--r--dev-python/pluggy/pluggy-0.5.2.ebuild28
-rw-r--r--dev-python/pluggy/pluggy-0.6.0.ebuild28
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
new file mode 100644
index 000000000000..d4e10441344b
--- /dev/null
+++ b/dev-python/pluggy/Manifest
@@ -0,0 +1,5 @@
+DIST pluggy-0.5.2.tar.gz 18935 BLAKE2B 8e5bbab9ed0c78a0c6da076ad03618e66780f9ff209f4d08223e7a381eb4d7573727793f4543799e0e557991d4edcdbfd22c0565b69814379806912a4631abf3 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb
+DIST pluggy-0.6.0.tar.gz 19678 BLAKE2B 79db59c5f0ce0dd157630d039ec50643f615789b6b993d84e9ab1bdc9ce04b32df336d88df13f13a16a1f0bd4acb7b900208e98c84f007bdc3654f9a1d5f19a2 SHA512 dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812
+EBUILD pluggy-0.5.2.ebuild 745 BLAKE2B aa43219d6e90d1705dbdcbd11b7ee7a2a1c186ed08d4832b9f9fc041e74c5bcae34d30c83584e77c020aa50db404788eb1f36c091f24573ecc45eb47ddcff162 SHA512 bd9af6d41e67f3c15204c41b4ec9bdad66a820bd463dfb28cfd6a96d47530f8bd942e31f707b56781e2da61643a9067b3463ef347ed78a1a35f3daa6cd8af651
+EBUILD pluggy-0.6.0.ebuild 762 BLAKE2B d53e3c80c9bb12d3e2fea4118d9212cf7007c5bbe00733ee42a0abcc5eb95ed62b745d98a724bdeef0f3a76200a58c3819d31b7ac4ca91e5563ba62e41f7824d SHA512 b063a43e5262bf900ce905d7c375e5130d447a6e9d435ac087b49fe7477e9195aa5061a083ce6d26ce02e8cf7e549cdb0bb361466be30230f3a04ad427cacdf7
+MISC metadata.xml 444 BLAKE2B 9b0b62a0670449bdfade395d9766e192088182f724deebd2a2ace8800ac5c0ff6f37da7174186434f727aa3bee08b9416e6dafae443cd01e01baaae741c899cb SHA512 2ecb5fb612627c44f3499080fcde9241daf2f25a974a8e24fe8190b7d5f8baa6a457b7a902e788f98fe9ed1fdb2cd0f46770337e8f836e430b0aa6f0d323ad50
diff --git a/dev-python/pluggy/metadata.xml b/dev-python/pluggy/metadata.xml
new file mode 100644
index 000000000000..972236293061
--- /dev/null
+++ b/dev-python/pluggy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pluggy</remote-id>
+ <maintainer status="unknown">
+ <email>holger@merlinux.eu</email>
+ <name>Holger Krekel</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pluggy/pluggy-0.5.2.ebuild b/dev-python/pluggy/pluggy-0.5.2.ebuild
new file mode 100644
index 000000000000..ed42e6d41295
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/pluggy/pluggy-0.6.0.ebuild b/dev-python/pluggy/pluggy-0.6.0.ebuild
new file mode 100644
index 000000000000..b594318c978d
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}