summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-0.13.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pluggy/pluggy-0.13.1-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pluggy/pluggy-0.13.1-r1.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.13.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-0.13.1-r1.ebuild b/dev-python/pluggy/pluggy-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..2e53a4f53a5b
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.13.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' -2 python3_{5,6,7} pypy3)"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}"-0.12.0-strip-setuptools_scm.patch )
+
+distutils_enable_tests pytest