summaryrefslogtreecommitdiff
path: root/dev-python/plotly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/plotly
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/plotly')
-rw-r--r--dev-python/plotly/Manifest3
-rw-r--r--dev-python/plotly/metadata.xml16
-rw-r--r--dev-python/plotly/plotly-1.9.6.ebuild25
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
new file mode 100644
index 000000000000..3918966be405
--- /dev/null
+++ b/dev-python/plotly/Manifest
@@ -0,0 +1,3 @@
+DIST plotly-1.9.6.tar.gz 546722 BLAKE2B 5905af517ef40bc077492f01b49c367c0aa03a96accb86ec072e188a43e463c187a0b9dee3d0df33669aa6d600ed9127b067c7099947e5235331d14ce10bf33c SHA512 7564036ed3745fc06ee7428942e45ca6bfaefa1e47b08a5868a918924268ee632515f1de4bf3e90911234f18a4d85b092ecb6ef9f213b939093dcb433a12dec4
+EBUILD plotly-1.9.6.ebuild 594 BLAKE2B 5af9a73cdf7c20dc5b4b230a029d2c72e547fb07299563470cac6f3a6daebcb07ec0d750731dbac37bc786bce67fa26b0628627ce6aeb307116243b09aebd65b SHA512 7938567a7ad3c8502529cf03bd5bf2d8c3701a7b946fc6b5a4db703cc0650e5c8358e7627436b5cac356ff96380aa9554d65794d9fdcb06cf07b5437f0345137
+MISC metadata.xml 601 BLAKE2B eb47eb35e1a4e00d798a5483413476bd98e4071845e7271e7a1982e8d0474c9f77d55105952b47d8676230ef1f2c89296172b26729b91b9403d73498be080645 SHA512 6a9af070fbe6fd992fa2131491b742c7d92c8fdc30993d1c92185c5bb4dbd42c9a9f84bbf6a9b710d5c731d820e3610d00258fcc284ea7388e1acf56fd3840b9
diff --git a/dev-python/plotly/metadata.xml b/dev-python/plotly/metadata.xml
new file mode 100644
index 000000000000..b92ec11d7525
--- /dev/null
+++ b/dev-python/plotly/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python plotting library for collaborative, interactive, publication-quality
+ graphs. Plotly is an online collaborative data analysis and graphing tool.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">plotly</remote-id>
+ <remote-id type="github">plotly/plotly.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/plotly/plotly-1.9.6.ebuild b/dev-python/plotly/plotly-1.9.6.ebuild
new file mode 100644
index 000000000000..5da6d85fe212
--- /dev/null
+++ b/dev-python/plotly/plotly-1.9.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"