summaryrefslogtreecommitdiff
path: root/dev-python/plotly-geo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 14:55:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 14:55:22 +0000
commit4c51ef39a9b443061a7071e002d7daa2a4d16141 (patch)
tree048b88a0effe40564f62448a2ff2779f637e563f /dev-python/plotly-geo
parentcd1445321d1a6609cc7215588a79b2232c8a9bd3 (diff)
gentoo auto-resync : 29:01:2023 - 14:55:22
Diffstat (limited to 'dev-python/plotly-geo')
-rw-r--r--dev-python/plotly-geo/Manifest2
-rw-r--r--dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/plotly-geo/Manifest b/dev-python/plotly-geo/Manifest
index e044bf486de5..63ab0b09a77b 100644
--- a/dev-python/plotly-geo/Manifest
+++ b/dev-python/plotly-geo/Manifest
@@ -1,3 +1,5 @@
DIST plotly-geo-1.0.0.tar.gz 23718591 BLAKE2B f78b36cd7ac6ec10e830f6be5758ed31ad2382882454d96ef652a73a11aa9b3be46ea24fd3f49a6189d9fd9eeaa89ca6777c691be9fc65f4d2a04a4d2bd58823 SHA512 977621c0fc84a6c72b2a91bcba27cc25b277f32cc87a7098675b3d7cb8c468a8291ef66397f3ceb45fbaa3484eba53d7649f809cf9d02af6309562af0b4fdf4a
+DIST plotly.py-5.13.0.gh.tar.gz 30683340 BLAKE2B 0e2c5638c766e5da6e2067d7be270576afed984b45deec0955fa10698d37bd082f3ebc568a8290c17554c672ef9e31cee81b0fae18b9f3249591fe62510ce5fd SHA512 c874b46ac43520519951aad55f93bfcfe03910873fd273f283fe16ae2a4150cfa35104be422c21b65785c77f468f084847278f76bce3d9179cc2a339809c42e3
EBUILD plotly-geo-1.0.0-r1.ebuild 405 BLAKE2B 8307bfd443258893871f60d37600a1ce35567959b054f140b1c50b8d099c6cb50ef25874f36d24c96202a0268a6c91f49cfc746492d9fa3620da943e6d44dac0 SHA512 d1a7f399e0b6f0e8453adf970ea95139e688f8feeb4d57a3591038b69c51e5c85157e458e3aeb3382e45507d9f301e1d4bb27fbe37ecd8ad2951b33d1c75d990
+EBUILD plotly-geo-1.0.0-r2.ebuild 898 BLAKE2B 69f42ba5acb69d09c0d288ea6efb1afff68b1524610f8077d86367d26166b70e65cc9b80b3ae9ff9801c15dea1a7f99c92b160f08f17b99b938c0e4556f563a1 SHA512 fe197f6864321b4ce9a59b4810d17a77927636313b72eec7d46026c4775212efc1e5d47b44a34435b3e58969b86a81a468e1aaef749f729cbbf6084a9b3add9e
MISC metadata.xml 606 BLAKE2B f750ac826d136a2ecd74b197686de4736a9caa8df6fc68dc526e3e0180e41874054e2ac6334910fc46588638ce5bc9c8c81af89265d8c6f19e1c52f332c5dd04 SHA512 3141ed25994bda29d72cbd0e6c2dee2b07d1d651379c75051b08b82de7f3463eab35ebc201dec642c75cb213bf6021985df0eaaa1d1357083ed41330e1d953bc
diff --git a/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild b/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..c3220f5d9a8f
--- /dev/null
+++ b/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+PLOTLY_PV="5.13.0"
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="https://github.com/plotly/plotly.py/archive/refs/tags/v${PLOTLY_PV}.tar.gz -> plotly.py-${PLOTLY_PV}.gh.tar.gz"
+S="${WORKDIR}/plotly.py-${PLOTLY_PV}/packages/python/${PN}"
+
+# The warning about tests not being enabled is a false positive.
+# Add distutils_enable_tests and restrict the tests to suppress the warning.
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+"
+
+# There are sphinx docs but we are missing a bunch of dependencies.
+# distutils_enable_sphinx ../../../doc/apidoc
+distutils_enable_tests pytest