summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 11:04:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 11:04:31 +0000
commit5944ce177026c93b7dab690db9d970567ddbf75f (patch)
tree98cde802bce7341b8039a2189a44a6e85f5a426b /dev-python/platformdirs
parentd0835364e1877539c2b8ce70c1941ebfedd2a91b (diff)
gentoo auto-resync : 05:12:2023 - 11:04:31
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest2
-rw-r--r--dev-python/platformdirs/platformdirs-4.1.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 850f7b363bbc..f80788f622a4 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,3 +1,5 @@
DIST platformdirs-4.0.0.tar.gz 19914 BLAKE2B 0ae3f7491f3f1d38561c89312c988b4145c9afb60e3d866cd05bef7e02c6df95d56cb230995de2893c0afd32bd63eb08448e67d5cdd0bdf6f3556ea1a23e2b49 SHA512 28eeb18ab5a52bf60d85ab76c986300d0f69c3bcff9ec18b961b70f97bce4e0d1bd3315b8d97f6b6a41de000b734979c08754780d282695525348342ab9c9931
+DIST platformdirs-4.1.0.tar.gz 19760 BLAKE2B d2deeb3d8300a92af0c0d69bcee2c02210d0cd32925ba7fdbd992723e13deba2a432bc7cb5eaf83ca9f576888d54d237b17028b25554bd65f044e61c0a353384 SHA512 f9cc171e7861cd9018be179963fc5d0316dc39a953b67dccf946937077704eb80955cca0d51c0edd8b4f931f705f719767f2b888be4276278891a099b5928fa2
EBUILD platformdirs-4.0.0.ebuild 1326 BLAKE2B 02a40864be04dfe30c609d82652dac8ea264fdcf5e5fa7802cccd67aea42fef23fa674fac448cbe4af75e22a60e029fe00ab49a82529b45e02786d36fbbd6107 SHA512 97ac223f0e44101860803b0a109f3ba4d9f521b43f30d7f3ae79cd6745819bfba6ca46464323da9a0483c8a0f466dfe406d3928fe567323e6579e7adfd4d97ed
+EBUILD platformdirs-4.1.0.ebuild 1334 BLAKE2B 200f71291e7e4d5986d17b6cdb7f2357eba9560c3b3a827f70ecdd590170b12fcb7a5d349fb249e2dcddcd5be2b17fcbd852bfa637cbf0f94c16ee07d43408c5 SHA512 4e6095aabd727e20f53ee1e381af4782910c33d1806c311f6394740a9b2cdaf7fe5491fc8408a7e0bbb090b8d4da1163404149e6ce1238823eae14a0a02b6772
MISC metadata.xml 383 BLAKE2B b8c8c1593d154e7a38ca4bc450c14ca21f2411ea1d71f67e9631c1def0acace43ebb6e67adc0c4a1f5f14aadfbce44d0d815fc3696410bef66c826fd5fb00a45 SHA512 f4ba6722e1cf661b3febe10bb15755a9cbc30226a08bdcabfa3d80be87b42d662d6a1edb3412ad79e8f36836a6dd4fd91a83dae29725ec47041056dc1f1f9b75
diff --git a/dev-python/platformdirs/platformdirs-4.1.0.ebuild b/dev-python/platformdirs/platformdirs-4.1.0.ebuild
new file mode 100644
index 000000000000..70e821d796fb
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-4.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}