summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/platformdirs
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest2
-rw-r--r--dev-python/platformdirs/platformdirs-2.4.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 89d8db42a0f6..2429613e0f69 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,3 +1,5 @@
DIST platformdirs-2.4.0.gh.tar.gz 19482 BLAKE2B 81ebc4424bd2845ae3b28d95428f95c7920300193ff98159263089b3db0d104a3a59af616bf6b815c0c8b1453d3f05d85120573c71b16b0a5104cc2532c472d4 SHA512 76b492f9d1a5c666c3c6957c775055bbd74db93f2a66f0651a74e1914626d757ab8110df87281cd31ad65abbd89f02906fdf8f0854a44f8500487685993fb8af
+DIST platformdirs-2.4.1.gh.tar.gz 20051 BLAKE2B 18fd11f7cae7c81c3615c89468d1deb3ceef3337b4a87a806b245b7bb5a4c14c0eb64fc7cfa06adc2da6150969da3a626da16c1f309f3011a9d4c5d1e4ca1d83 SHA512 d410056207506395c922ecc36c481bcc21f8dd97c69f33dc13580c74d0ea3d1aaa97284b79eed47b723f18c663038874edc5b9c4f4def06d92f1e25f7a8d76b4
EBUILD platformdirs-2.4.0.ebuild 795 BLAKE2B 8b7da01e8aa80ee1f1e00371a92933323a79e679f69d88add7f605ff3986a4957ce5945ff827239b08c1a81ae28f25060250f6927aa4471350d6b80f5d10112e SHA512 2f8ab22cda1121989638f7c58451d8391bd74b6b5011f1b6fccb8237c60af6131435c47fe2874c53e516fe1032bf21708afb1910ab900b4f5e2b6165d1ef39d6
+EBUILD platformdirs-2.4.1.ebuild 803 BLAKE2B c767e7b83c0df2330bacbd45fca203c331d4abd71d54231fa40af88ad15ba7ab5b1ba787daa9fd7950137f0b77917aa711ca4cbd7c1a2318e37798296acb5809 SHA512 fec658124062fe60fa5d7ba8d92b68774506b88f49fb3f8bd8c988439b2a1a0a8ba3f3cedef4f5abf4ba65be9a8a1cf864264d9225c78d09560c034abddd1fae
MISC metadata.xml 383 BLAKE2B b8c8c1593d154e7a38ca4bc450c14ca21f2411ea1d71f67e9631c1def0acace43ebb6e67adc0c4a1f5f14aadfbce44d0d815fc3696410bef66c826fd5fb00a45 SHA512 f4ba6722e1cf661b3febe10bb15755a9cbc30226a08bdcabfa3d80be87b42d662d6a1edb3412ad79e8f36836a6dd4fd91a83dae29725ec47041056dc1f1f9b75
diff --git a/dev-python/platformdirs/platformdirs-2.4.1.ebuild b/dev-python/platformdirs/platformdirs-2.4.1.ebuild
new file mode 100644
index 000000000000..39dce3345f62
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}