summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-python/pkginfo
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest4
-rw-r--r--dev-python/pkginfo/metadata.xml17
-rw-r--r--dev-python/pkginfo/pkginfo-1.9.0.ebuild35
3 files changed, 47 insertions, 9 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index 7a545f48efb6..70df16c13a50 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1,5 @@
DIST pkginfo-1.8.3.tar.gz 375734 BLAKE2B a3e9779bcb7cd326d8bd8137fa388055032fd4ee7732d47a341807201a97f1d44652d8e46adefd301cf7cd3c1d041e49a6ed2b8752e12347a8a2a2349cf397bd SHA512 54a67bdf078b38600651cb94afa62e9d86fce512022b1e79eb4565289ae3fad2325647654704488968e18cd85cbba4bd0ce28392fd09ae9638ee449e802273eb
+DIST pkginfo-1.9.0.tar.gz 376601 BLAKE2B 1823140bcd109cf2549f0c7f8db4315880a86030a8400838755664794a7cac94998a6a20832db6b29d5f8623fc16d0bed477eb48750184ba04b6440063d6bf02 SHA512 5189929a80aedbeb65ad3b243d6f916854887e34d3489eab71a6ca69ab82d0fb2cc62ec7a49999890eb323be981d35505a6f47d2debc83cfa1cc8bb04523dcb0
EBUILD pkginfo-1.8.3.ebuild 675 BLAKE2B 0bc2a787bc673fc106f50b484bb9987b99cefd880e13b3dd1b9b91da211b496152b8de428ffee896ef00683c8db9c9ef4d25dded995a19a95d186484f1b2fa65 SHA512 4c33fa944601b4b831efcdd606dd36b9417b11a49d612421b2e8fa6146d3980fb0a4d5d0fccce36c1816b8ca335c29b8a4c7e5511ce83f1241b6da2af69131da
-MISC metadata.xml 346 BLAKE2B b5a7868643825a1bd22054657ade61cf2470a128044535fef6781c9319f1e0e240638f74232f6e4fed110421cb56c2ad6cc1c98e49ff8c1acb88585465829470 SHA512 00afd3ed2f6cc2e2806845dd0b96ee154dcaa73ee036d27a8e3bd6c85f2445fca1cd4948cf60b9f424d41ef3b67941d564f831008b1e18ef8952ccadbdbc8001
+EBUILD pkginfo-1.9.0.ebuild 926 BLAKE2B fb892aa3d81b82da2a8990c05b32cf7638a626dfadb5e7af5e18dc878a739c23b023985df52235865dde6d21756eeedb25138228cc89c1c5ea7e1b38b5ddd7d7 SHA512 fc71e7a1083f4580cae525997b0dd709370cf7b8e319a350afe2370791e256f5c8a88c7220533e3eaff1f58ea8a0c46c67d94ca7cf19a2909c7cf82cb58a7782
+MISC metadata.xml 385 BLAKE2B da3779a71a7d23a535599d8854c970725b3e6c121642cfabbabccc0e97cc1dab0cf77452da565c9efbd8044cb02cb2fbe00687a0b312948298902e4eb1f4e498 SHA512 fcd65e87146d573c1bc33dc560ed419ae5d4e46e6ba423da1a6dd46ce96683d3ffeef75b640ee671f16865e34293695b48a5fef89ee754a8b6bb797a03c13b08
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
index a5d27a3bba00..beedff34f048 100644
--- a/dev-python/pkginfo/metadata.xml
+++ b/dev-python/pkginfo/metadata.xml
@@ -1,12 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">pkginfo</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pkginfo</remote-id>
+ <remote-id type="launchpad">pkginfo</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pkginfo/pkginfo-1.9.0.ebuild b/dev-python/pkginfo/pkginfo-1.9.0.ebuild
new file mode 100644
index 000000000000..263179ac56d4
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # fail because of extra python 2.7 classifier
+ pkginfo/tests/test_utils.py::Test_get_metadata::test_w_module_and_metadata_version
+ pkginfo/tests/test_utils.py::Test_get_metadata::test_w_package_name_and_metadata_version
+)