summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/pkginfo
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest2
-rw-r--r--dev-python/pkginfo/pkginfo-1.9.3.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index cb9a3ab825a3..b7fcdad5229e 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1,5 @@
DIST pkginfo-1.9.2.tar.gz 377091 BLAKE2B e217e3d58fbc7a4efe7321d1eb4f6c95ea75cfcdcbdd06c0f8b728eb1ec18c5800a7ed6f6338996c60f5f251f36d40b40c20d0b1700956dd8a23a6e40594a356 SHA512 16eb4708040811a21184e5fff1bbbde775360718fa67df97f56c646381f6f1e58967920753437e5759e4d88c31a4f10c1e4d8be2380981939e51e4ee140dbeda
+DIST pkginfo-1.9.3.tar.gz 786745 BLAKE2B 6b5c507073a30900e9325c68e437594fee0e491199a38de19baea0170453d84031441ab7a08387d5b3d363f8b77ec971ef6c36dd72154114041e724c17f4eb1b SHA512 452893a2fdc99068ea780f11d1a54bc5c0f99a2ec7e1ced2ec43a0703c85af24e61b6d80c0724981fab9b6e0caa3e2e98882f34d3edbe8b187ea16d66e120dcc
EBUILD pkginfo-1.9.2.ebuild 675 BLAKE2B 0bc2a787bc673fc106f50b484bb9987b99cefd880e13b3dd1b9b91da211b496152b8de428ffee896ef00683c8db9c9ef4d25dded995a19a95d186484f1b2fa65 SHA512 4c33fa944601b4b831efcdd606dd36b9417b11a49d612421b2e8fa6146d3980fb0a4d5d0fccce36c1816b8ca335c29b8a4c7e5511ce83f1241b6da2af69131da
+EBUILD pkginfo-1.9.3.ebuild 683 BLAKE2B 736af0b5afe2964ecb1087410da44cac1d69e171b14396488f32bbc5a928d3eea3aa9658e637cee7e9638d5d840c8a7ecbeda63a62bab68bdf639da5bfa4dec9 SHA512 f743546375aa9b01ddc21bac2e6e58858f49c876882611cb65a13182a107ba1504c3c643d5538bd493320744eafcc4aadd6d2c4cc8133a861ec018fe0333184d
MISC metadata.xml 385 BLAKE2B da3779a71a7d23a535599d8854c970725b3e6c121642cfabbabccc0e97cc1dab0cf77452da565c9efbd8044cb02cb2fbe00687a0b312948298902e4eb1f4e498 SHA512 fcd65e87146d573c1bc33dc560ed419ae5d4e46e6ba423da1a6dd46ce96683d3ffeef75b640ee671f16865e34293695b48a5fef89ee754a8b6bb797a03c13b08
diff --git a/dev-python/pkginfo/pkginfo-1.9.3.ebuild b/dev-python/pkginfo/pkginfo-1.9.3.ebuild
new file mode 100644
index 000000000000..189ee54e0857
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs