summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /dev-python/pkginfo
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest2
-rw-r--r--dev-python/pkginfo/pkginfo-1.4.2.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index be2ad4213e37..62a1ab89f3dd 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1,5 @@
DIST pkginfo-1.2.1.tar.gz 31072 BLAKE2B 57ce5f6147b97af513dfdc6137180e5561822096cdbd21b673c49522384622c58f9eba8c65f24b54bc1e76dc0c6feede5d43e8aac945d94ffe79ea220e830470 SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a
+DIST pkginfo-1.4.2.tar.gz 33539 BLAKE2B d3cfc6bf7a9e748902b1f63434c745d8abf4e144c0a2b5d7a90236bfc2ce7f94922b0e08e5a08b13ba2025159bd90fecee25d9abdb283e7d52de0d34386aba59 SHA512 536628a2a2472e999695a115449a76f971453aea7ac3a08f10d9b08dfdf4a7b8e67c6010c6f18d300472a6afc8dff33331c955cc2f7bdb357504cd6a36390da3
EBUILD pkginfo-1.2.1.ebuild 1404 BLAKE2B f78e5e721aa3532b5b8faf2e83622cfdc3351dbeb1b29864204f0cfbca37e5e928783df45af56346adb3c2261d8a51c0e071bcf0df45e7ae84e0f990bb043973 SHA512 586dc0ac518fd8cbe9d438659d4f3cf922c7479f26d0ce439b81dc812baf0044e5b8ffe15feae12df55ce53f6f45501a9e09e735486e84594d93b369f2b305c2
+EBUILD pkginfo-1.4.2.ebuild 1343 BLAKE2B bda79c2bf65bcf58dbaabaa71b033e37b8486cdc7a5e4f604faf8f88fd9f93d68d573552179ecc971b3ffad50985112415c62cb6411df467eb315b35b4a354d6 SHA512 a0eca4c824909c9cfc503486338b466c52daf5e07cb877d5cfa613824152430df4f2bb02ea904a69cd27ebe96bc1280ae7d2b828c61e33cddb0d31d1773c8ee0
MISC metadata.xml 320 BLAKE2B 70ca2a2666e83f11a892b1c3e155512ebb6992f2b02911aa86609ba66ac72ce4c5af72acf513c92b6a9d542d510379ed6963a94a4a1e16d0909c2461e8b6d5ee SHA512 8f2cf51568e86fb0ebbaf5eb2476f6c7f7121abecec606626aafe5395b2e9530009e77be890d389daa563b6ee47af311cbdeb121518351b0e99da0c591c0502c
diff --git a/dev-python/pkginfo/pkginfo-1.4.2.ebuild b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
new file mode 100644
index 000000000000..a006ae9cbcac
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable tests that seek to read the version of pkginfo from an installed state
+ # These test will still become installed and testable once installed
+ sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+ -e 's:test_w_module_and_metadata_version:_&:' \
+ -e 's:test_w_package_name_and_metadata_version:_&:' \
+ -i pkginfo/tests/test_utils.py || die
+ sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+ -i pkginfo/tests/test_develop.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}