summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pkginfo
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest5
-rw-r--r--dev-python/pkginfo/metadata.xml11
-rw-r--r--dev-python/pkginfo/pkginfo-1.2.1.ebuild47
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
new file mode 100644
index 000000000000..b43d27ff340e
--- /dev/null
+++ b/dev-python/pkginfo/Manifest
@@ -0,0 +1,5 @@
+DIST pkginfo-1.2.1.tar.gz 31072 SHA256 ad3f6dfe8a831f96a7b56a588ca874137ca102cc6b79fc9b0a1c3b7ab7320f3c SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a WHIRLPOOL 1ab43db82665e0abed88bf59115df726475ba7c611b077803721cd6bfcfcc81120c7a996e8945e74ad18c1ec7f6c9e5a1396df37d4f2c0eca24924f4c22e9ee3
+EBUILD pkginfo-1.2.1.ebuild 1404 SHA256 c64c87a93dc67047b9f8b3c529f8ee9149f65fcd5c228046137f287283efb355 SHA512 586dc0ac518fd8cbe9d438659d4f3cf922c7479f26d0ce439b81dc812baf0044e5b8ffe15feae12df55ce53f6f45501a9e09e735486e84594d93b369f2b305c2 WHIRLPOOL 56d9ae623715e518524f51000c47fd549832ca4e0cf1f3e450c254e2e2b6d6d4d6bc309821f6f0942130fac9cdfa961107145e5ed9a9c25b930247c1f2598077
+MISC ChangeLog 3918 SHA256 2f6ce8856ad91ae06afcdfbc13ab8b8a0768f5e9b8000912282d48b0880d0f39 SHA512 c53bcc16f0085f3b29a3ac0ebd54712e5c4d9efe7c45989a2e42fc45aeb95e819aafff6c32fcda5ffc007c0c3d598ce793f7de8433122d9fe56e40c7df5247e6 WHIRLPOOL c30031f7de1339e2740de7347acee98fa172d7f6592a0d31558d027fe0e92a6306aa072a598e3198577834c4812c6862893961807ca3645f16fbe00f5f42057a
+MISC ChangeLog-2015 1808 SHA256 9b22014c9e4b809e8f2d76e43c1b977a29f161244efd97d631ac07e03bf89c26 SHA512 0af8a8884d2d3ddb65777b81b6e45d9963e293debc8de38e18d9d50cf7b750c525ab4bff0e2ebef941ed423fb7566b6d63cf23c03eeaa815c57384c76315a600 WHIRLPOOL a8536d1c2aad51e9f3ec0a2527b6b3310df33b1c0f19588c7a3c4ada94cee6d6cb21c76b425e0c8803296e72ba1579f54f0624e44a65135ad57a590962fcbef1
+MISC metadata.xml 320 SHA256 8d9cbb543e05091243392dc3ab75e435df6221d970bdb6b37921392f816fb85e SHA512 8f2cf51568e86fb0ebbaf5eb2476f6c7f7121abecec606626aafe5395b2e9530009e77be890d389daa563b6ee47af311cbdeb121518351b0e99da0c591c0502c WHIRLPOOL 5dc63362931063f65d0ff9fd195b4cc1d347eedbb173b188bc6d7dbc3753c48f74888f6e8ab83ab7b024c00285d74427a742089bd698629123c7239cfb97d891
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
new file mode 100644
index 000000000000..c10553350506
--- /dev/null
+++ b/dev-python/pkginfo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pkginfo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkginfo/pkginfo-1.2.1.ebuild b/dev-python/pkginfo/pkginfo-1.2.1.ebuild
new file mode 100644
index 000000000000..dca8bf6c63ac
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+IUSE="doc examples"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # Disable tests that seek to read the version of pkginfo from an installed state
+ # These test will still become installed and testable once installed
+ sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+ -e 's:test_w_module_and_metadata_version:_&:' \
+ -e 's:test_w_package_name_and_metadata_version:_&:' \
+ -i pkginfo/tests/test_utils.py || die
+ sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+ -i pkginfo/tests/test_develop.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test ${test} failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ use examples && local EXAMPLES=( docs/examples/. )
+ distutils-r1_python_install_all
+}