summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-python/pkginfo
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest2
-rw-r--r--dev-python/pkginfo/pkginfo-1.7.1.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index de6b58c6e512..463a31c98d84 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1,5 @@
DIST pkginfo-1.7.0.tar.gz 37209 BLAKE2B 70e2c7d69d4b9b5544017c0b0c388e375060f063a35a3467a420d8819d77eb0e9772735db78c0ad03560aa9e35dd0485945517f305056bd52d435e2462a3878b SHA512 0e41899fac552e6a3c401c7dab3e3cd57f31cc5f052e07537f15b699c85113800edac27d232571ecab4852fab1d73374eca381d1ab70c9a7461bb422ff03de3b
+DIST pkginfo-1.7.1.tar.gz 34280 BLAKE2B ad928cf80423977e5944e3110150afb3e5ae416bf1fd28aec8099c3f25e41956b49e4134cdee5e0621e5bdff44d7161c3b1783b3c6d15555eee86e2e14c29fbb SHA512 5b6374e45e7ccd68f3a28145c2fc350e630e97fcc5e97d46d05c32f0958a51e4713487b809099ddf0a9ab07840f7fb4409438ab7b7a9b0b05e94d292088b2c26
EBUILD pkginfo-1.7.0.ebuild 670 BLAKE2B 31940e10fc7ebdc0efa3dae6b747ba2aedea057fa544202a2a2145586fe4a6a1a7ae66ec5f7ace67442379cabd2d9adc35710076e1f55de56459be8bbbb68d41 SHA512 affe6071bba09aa82a2719e42906a03a7c4c3343039994f1c5b2303ac0610b8f07343a6ddd33f0d2660e450399ed7b47779e3bae4c5768e0c10af138b4d2047d
+EBUILD pkginfo-1.7.1.ebuild 535 BLAKE2B a43378212cf468144387af910720c1dfc997ea732de2df69f515b0074ab7c8977809f40f3896f09ae819110e642719a65b828a599b54eef8f76f53d3f919eed1 SHA512 4baf561f206d8230c5e3fc3ade58fcf5a0bb07b1ebbdc7e26dd38969cbf2297943c928551d2a2e98b0e4cddf179db6c78a23bdc9fe494d169d1f260352f55b9f
MISC metadata.xml 345 BLAKE2B bae902e9e5c7357ce7df1d26ddb2c4c81ca0dbcf4d17eeef7127a49cc4a17794ba29483049ebd5518df71e18258c4ad375a90e0bfb2052fa95a9143431095662 SHA512 f970952fd577c2baadebf824932c4e825d962a497d7f41870a6d51301a5776d22809b923efcdf2ecb38322e4c53e11dbeb5083660ff0f93a3c301a88bb807151
diff --git a/dev-python/pkginfo/pkginfo-1.7.1.ebuild b/dev-python/pkginfo/pkginfo-1.7.1.ebuild
new file mode 100644
index 000000000000..3e5a9ac19e76
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.7.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs