summaryrefslogtreecommitdiff
path: root/dev-python/pkgcraft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-25 11:25:16 +0100
commit70a8e0f526762c28622fae5f944f8f59f9abf728 (patch)
treea58f1b704c29cff0ad8201d20ebbf7a11018f88f /dev-python/pkgcraft
parent4eda0fe5576868e6c7f97b51aa1c279ff8cd320c (diff)
gentoo auto-resync : 25:09:2023 - 11:25:16
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest2
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.5.ebuild78
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index f864b9022ac6..692262374396 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,6 +1,4 @@
-DIST pkgcraft-0.0.5.tar.gz 400237 BLAKE2B de78c1570ce8080742d3afbff2c9078b56fb14e7b097bd09b47c5b21a5de1062989835c9c12e4efd9d4be4aef7e9dec1350606700d80c5482cf81d1d2c4febc0 SHA512 2366180189314cafa4be8a180eed62a8c994bfd862ebc5292e01d9cd2585b9eca082535e405924ad758d6f89309c5e64727242a52f95f6e71aa6aff3495edd57
DIST pkgcraft-0.0.6.tar.gz 406538 BLAKE2B 5c90b57cb11e9f754cd695989994b3a9be52007482981c997f2e361fbbb72aeb0810d7f41dea1cdcd74c47840bb1c3b2cf225c967ba76b01769da93f909d9911 SHA512 ddd7bf77a3509156e8c16e5aeeb94a5f4530d9d1a3e6617d3974adfae7b46f0b0d31f4828dbd70261b42c883e776bf7572ca2fe8e23c9216637d886b9d8811cc
-EBUILD pkgcraft-0.0.5.ebuild 1892 BLAKE2B 13713a1d09b9a72baa53085b22d41f05cc5181aed2a944961cf7b94a5aedd371b4a82d390489cb8a51b896da64287ddcb83fae3b05d1d1bb2bb0498c754c3f85 SHA512 d6fe89e517c85881d465724965e19f2e8a2c8aed188161383d6d65314a88a0724946d3d8dc88022832b74cd3e804a7906eeaad83d9ec0871cfc429260f68cca1
EBUILD pkgcraft-0.0.6.ebuild 2012 BLAKE2B 2414b04006aa23a6e1888118f306f0fb5286046c462ae307a143195373d0e7da7741580a2db4d84f9958d8a1ed412b5bb0b4214b9bdd7bbcf44dd01d725d0e28 SHA512 18262f24524878ddb7112c582295f74c10f5e52eb4a0f1fe64016d150f6271b89a85ebf3eb482034408641cdaa1a86a1b1a8d697f1a588db3faade8aa7197cfc
EBUILD pkgcraft-9999.ebuild 2012 BLAKE2B 2414b04006aa23a6e1888118f306f0fb5286046c462ae307a143195373d0e7da7741580a2db4d84f9958d8a1ed412b5bb0b4214b9bdd7bbcf44dd01d725d0e28 SHA512 18262f24524878ddb7112c582295f74c10f5e52eb4a0f1fe64016d150f6271b89a85ebf3eb482034408641cdaa1a86a1b1a8d697f1a588db3faade8aa7197cfc
MISC metadata.xml 454 BLAKE2B 5085311aaebe3c2cc696fee5da4ee272e47936a4f729c2007efce94097087a987985fb972df477fb72eead3402555924ca8b8f183b69af357453ad93daeb946e SHA512 ba7457ec4b43f1664042599d4e23506e496d1f2212ea7aa02c58fd9d796915dace2817bfb1c71e6f022e9490215248e2a705b223a087d91255b97b23f82f9c23
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild
deleted file mode 100644
index 41cf2f45a0f4..000000000000
--- a/dev-python/pkgcraft/pkgcraft-0.0.5.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for pkgcraft"
-HOMEPAGE="
- https://pypi.org/project/pkgcraft/
- https://github.com/pkgcraft/pkgcraft-python
-"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
- inherit git-r3
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="9999"
-else
- SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
- S="${WORKDIR}"/${P/-python}
-
- KEYWORDS="~amd64 ~arm64"
-
- PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.6"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+examples"
-
-RDEPEND="
- <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
- >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/cython
- dev-python/setuptools-scm
- virtual/pkgconfig
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if [[ ${PV} != 9999 ]] ; then
- local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
- if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
- eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
- eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
- die "Mismatch between setup.py's MIN_VERSION and ebuild!"
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install() {
- # Conditional because these aren't installed officially right now
- # and the naming is just for convenience.
- if use examples ; then
- while IFS= read -r -d '' file ; do
- python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
- done < <(find "${S}"/examples -type f -executable -print0 || die)
- fi
-
- distutils-r1_python_install
-}