summaryrefslogtreecommitdiff
path: root/dev-python/pkgcraft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
commit519f4aac6d5896fe0204e6429485f95240c7ff58 (patch)
tree467adac90d818b96465a433b66ef6bb65e369fef /dev-python/pkgcraft
parent8afe4133ba3d8586301516885427809020a3cafa (diff)
gentoo auto-resync : 05:02:2023 - 21:17:55
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest6
-rw-r--r--dev-python/pkgcraft/metadata.xml15
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.3.ebuild74
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.4.ebuild76
-rw-r--r--dev-python/pkgcraft/pkgcraft-9999.ebuild76
5 files changed, 247 insertions, 0 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
new file mode 100644
index 000000000000..8db2816003e2
--- /dev/null
+++ b/dev-python/pkgcraft/Manifest
@@ -0,0 +1,6 @@
+DIST pkgcraft-0.0.3.tar.gz 1239742 BLAKE2B c9148d3ac34d80c47db5d1080b3806e6b64fffa226d595a11499215626342286efc19b86fd1e158a8ca0021ab8946d35e4393fceaf8a318c258114a6c2e1ffdf SHA512 53ae196d073271654807ef5587c38d83e10b606f59baf63e3c8da7ce1b1d80d7acd1e3e201ebba1346c14d101eded666d6ad9bdf972b36c574c9b494147baa4a
+DIST pkgcraft-0.0.4.tar.gz 397121 BLAKE2B 72b24d34b6c3b6114a5d182b4fe562078aa258a21271b33d8858c85cca480a932afab5933978295fd44d531146d58688391efe8e23f358332de83ae5195d68fb SHA512 04996bcbe6d9a8ae6082ea84a63358f42d3a503f1e0d188b627b033b8379cf6e22f5ae8ff764b7213fe6d801a1eeb6321b02967e77d98575125e16781d9b917c
+EBUILD pkgcraft-0.0.3.ebuild 1669 BLAKE2B 34ddfe21de878010bb5c4619142c0deed93b9be8463dec4f3b8ac9f081f2f66d1bf39db905f60f140e216b91d0edee8e5bc8c8051ca9f07bf68516c3df40c56b SHA512 53e44ec94bbb6c36470876b6d077d604ce3c2a6aacdc673772b851a4f6ea04bc54413088a49797adc16db6bb4939ddea1c5e2479223a286b1025aacb58b3e224
+EBUILD pkgcraft-0.0.4.ebuild 1812 BLAKE2B aba3827fde71387e9aa0ad16cf7bb63e62908f09a35648b5804ec877c638d5bc89ff465e2ee28d382df54d0313ddaf196a4d4aba0a8177e2a3e1759b01b93ff2 SHA512 6aa91048d1d1e7d57882b4dad5814cb762fe36ec524b6b26e0093718a2163d8d9817d307cc6088ff1245a15d74a1e80ad26248e1e1de680d3157cb00a209d583
+EBUILD pkgcraft-9999.ebuild 1812 BLAKE2B aba3827fde71387e9aa0ad16cf7bb63e62908f09a35648b5804ec877c638d5bc89ff465e2ee28d382df54d0313ddaf196a4d4aba0a8177e2a3e1759b01b93ff2 SHA512 6aa91048d1d1e7d57882b4dad5814cb762fe36ec524b6b26e0093718a2163d8d9817d307cc6088ff1245a15d74a1e80ad26248e1e1de680d3157cb00a209d583
+MISC metadata.xml 454 BLAKE2B 5085311aaebe3c2cc696fee5da4ee272e47936a4f729c2007efce94097087a987985fb972df477fb72eead3402555924ca8b8f183b69af357453ad93daeb946e SHA512 ba7457ec4b43f1664042599d4e23506e496d1f2212ea7aa02c58fd9d796915dace2817bfb1c71e6f022e9490215248e2a705b223a087d91255b97b23f82f9c23
diff --git a/dev-python/pkgcraft/metadata.xml b/dev-python/pkgcraft/metadata.xml
new file mode 100644
index 000000000000..39d39075985d
--- /dev/null
+++ b/dev-python/pkgcraft/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pkgcraft/pkgcraft-python</remote-id>
+ <remote-id type="pypi">pkgcraft</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild
new file mode 100644
index 000000000000..5dc743ca3d03
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-0.0.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MIN="9999"
+ PKGCRAFT_VERSION_MAX="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64"
+
+ PKGCRAFT_VERSION_MIN="0.0.4"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+RDEPEND="
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython
+ dev-python/setuptools_scm
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild
new file mode 100644
index 000000000000..a9b364218f73
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-0.0.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MIN="9999"
+ PKGCRAFT_VERSION_MAX="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64"
+
+ PKGCRAFT_VERSION_MIN="0.0.5"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+RDEPEND="
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython
+ dev-python/setuptools_scm
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
+ eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft/pkgcraft-9999.ebuild b/dev-python/pkgcraft/pkgcraft-9999.ebuild
new file mode 100644
index 000000000000..a9b364218f73
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MIN="9999"
+ PKGCRAFT_VERSION_MAX="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64"
+
+ PKGCRAFT_VERSION_MIN="0.0.5"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+RDEPEND="
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython
+ dev-python/setuptools_scm
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
+ eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}