summaryrefslogtreecommitdiff
path: root/dev-python/pkgcraft-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
commit736633fa866abdd7c155cabb02adf278c5237640 (patch)
tree847aff3277bceae8b34d29ff6c16cac3ad4b288e /dev-python/pkgcraft-python
parentf926b97bb4ca0ec30c10ee9075bd3fd3b1df2be7 (diff)
gentoo auto-resync : 22:01:2023 - 12:52:10
Diffstat (limited to 'dev-python/pkgcraft-python')
-rw-r--r--dev-python/pkgcraft-python/Manifest4
-rw-r--r--dev-python/pkgcraft-python/metadata.xml15
-rw-r--r--dev-python/pkgcraft-python/pkgcraft-python-0.0.3.ebuild74
-rw-r--r--dev-python/pkgcraft-python/pkgcraft-python-9999.ebuild74
4 files changed, 167 insertions, 0 deletions
diff --git a/dev-python/pkgcraft-python/Manifest b/dev-python/pkgcraft-python/Manifest
new file mode 100644
index 000000000000..c7af868d00e5
--- /dev/null
+++ b/dev-python/pkgcraft-python/Manifest
@@ -0,0 +1,4 @@
+DIST pkgcraft-0.0.3.tar.gz 1239742 BLAKE2B c9148d3ac34d80c47db5d1080b3806e6b64fffa226d595a11499215626342286efc19b86fd1e158a8ca0021ab8946d35e4393fceaf8a318c258114a6c2e1ffdf SHA512 53ae196d073271654807ef5587c38d83e10b606f59baf63e3c8da7ce1b1d80d7acd1e3e201ebba1346c14d101eded666d6ad9bdf972b36c574c9b494147baa4a
+EBUILD pkgcraft-python-0.0.3.ebuild 1671 BLAKE2B 827a3e27229295cee2c8dafc2db2fb681b9c28727a571db1acce3b7cdaa59da43c8e4cc25f778aadc92b16eb21848ad711b1f62c8a2883e1c2820fee63c5e6c2 SHA512 330e7378f0c9d4436cff9fc3022d1354452997c8e680d6c92a22d1a4c02b18430354924b360bea99f3dda9fb291ea0b3d34a60455f2ccb899e7e05eb9255c145
+EBUILD pkgcraft-python-9999.ebuild 1671 BLAKE2B 827a3e27229295cee2c8dafc2db2fb681b9c28727a571db1acce3b7cdaa59da43c8e4cc25f778aadc92b16eb21848ad711b1f62c8a2883e1c2820fee63c5e6c2 SHA512 330e7378f0c9d4436cff9fc3022d1354452997c8e680d6c92a22d1a4c02b18430354924b360bea99f3dda9fb291ea0b3d34a60455f2ccb899e7e05eb9255c145
+MISC metadata.xml 454 BLAKE2B 5085311aaebe3c2cc696fee5da4ee272e47936a4f729c2007efce94097087a987985fb972df477fb72eead3402555924ca8b8f183b69af357453ad93daeb946e SHA512 ba7457ec4b43f1664042599d4e23506e496d1f2212ea7aa02c58fd9d796915dace2817bfb1c71e6f022e9490215248e2a705b223a087d91255b97b23f82f9c23
diff --git a/dev-python/pkgcraft-python/metadata.xml b/dev-python/pkgcraft-python/metadata.xml
new file mode 100644
index 000000000000..39d39075985d
--- /dev/null
+++ b/dev-python/pkgcraft-python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pkgcraft/pkgcraft-python</remote-id>
+ <remote-id type="pypi">pkgcraft</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkgcraft-python/pkgcraft-python-0.0.3.ebuild b/dev-python/pkgcraft-python/pkgcraft-python-0.0.3.ebuild
new file mode 100644
index 000000000000..18b5c4eb6c8d
--- /dev/null
+++ b/dev-python/pkgcraft-python/pkgcraft-python-0.0.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MIN="9999"
+ PKGCRAFT_VERSION_MAX="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64"
+
+ PKGCRAFT_VERSION_MIN="0.0.4"
+fi
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+examples"
+
+RDEPEND="
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython
+ dev-python/setuptools_scm
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft-python/pkgcraft-python-9999.ebuild b/dev-python/pkgcraft-python/pkgcraft-python-9999.ebuild
new file mode 100644
index 000000000000..18b5c4eb6c8d
--- /dev/null
+++ b/dev-python/pkgcraft-python/pkgcraft-python-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MIN="9999"
+ PKGCRAFT_VERSION_MAX="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64"
+
+ PKGCRAFT_VERSION_MIN="0.0.4"
+fi
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+examples"
+
+RDEPEND="
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/cython
+ dev-python/setuptools_scm
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}