summaryrefslogtreecommitdiff
path: root/dev-python/pipx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 01:57:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 01:57:57 +0000
commitfa3c4c282d03b85eb600bae6ec57b619004feb5a (patch)
treee427243594c435e7223f05759d54ec8f412e67ea /dev-python/pipx
parent0a3d5f62f59ea08933fd51b22c8c35ea85e2ce7c (diff)
gentoo auto-resync : 04:01:2024 - 01:57:56
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest3
-rw-r--r--dev-python/pipx/pipx-1.4.1.ebuild45
2 files changed, 44 insertions, 4 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
index 402e53e6a992..b72bbb4c1c7f 100644
--- a/dev-python/pipx/Manifest
+++ b/dev-python/pipx/Manifest
@@ -1,5 +1,6 @@
DIST pipx-1.4.0.gh.tar.gz 357942 BLAKE2B 34b0ede5a5160c8a5fcdff81c4902e0119041e7740b165c3a384234ba8362fa95db8002778a8987b4f93d9bd132152868171bb1627987c4cb7f4eb1cf2e4cc84 SHA512 5a0cd494ed6a4faa3f9f5cc5c56ee8ce9f27b3a456ad2eed2eaf5a9d175ea97209b2ec7b95e1500e1126ec066660f344f942692916cef552c39f49b2669160c9
+DIST pipx-1.4.1-test-shim.tar.xz 76316 BLAKE2B 25200c9519f8e916cba3933b4df3cc808d5575ac055c4465dbd4cf0ced92bc7f0bca5c448e324b9d61a0cf70710f584cfba6106859ffcccf42e0f59910b81cd0 SHA512 760ad73c67588747bed91b7172821a8e899e52fff8966836d7a2b3dc8cd3946006c76fdcae0320364fe0cb5afc8b51dd583c0a3720099812702fb585b98b9fef
DIST pipx-1.4.1.gh.tar.gz 357978 BLAKE2B 2ef4f303eafacd84d4b157043a03dc9365708882080bddb1cbcbf16910686ad65938314953a1d1b5be86243fb614f7b705dd91362cd3d7199434147004d529e7 SHA512 04fa29b02a25f21544ae2bbc86fa927fd3c03f98b3f1bd6beee318cbb34849edfbd553fb3b9f94015aab16039aa49f706092a75bd2f865f04dec56a34da43f1f
EBUILD pipx-1.4.0.ebuild 1015 BLAKE2B f485027bfea36ae7437318770b311a066fc733c02e1def5e131cfcc49d54663e7cb08acaef41c44b51d3c48e01595d257b991a1457fb001cd2465ec894557438 SHA512 0ba78cc0064af06a5eb9251307badd83191d0c34db2417ba0e32167ef64e2c564abf489b4e7f0b3de4bf6ac93343862e689092a8d491cefc969c96a018d94716
-EBUILD pipx-1.4.1.ebuild 1020 BLAKE2B 4fb48a4dfe04c9160322d98d47b656328189284cf8f300079f12c9eae5bab326c5b9496b4f03b7561f73614dc832eded03e51634f183e8d136109519a5b25c8b SHA512 5ffdfdaa4e1ba555bd1174ac1ef66c465e522e8c1aa143b4403691b3e03f489e603afcc5073d49df7f95407246d8cfc03c15c9db585857d0ca36be3c86176d46
+EBUILD pipx-1.4.1.ebuild 2180 BLAKE2B a1c18a90aff23900b093319b32fc6d7d732034d1182764f29631440be8c5d172aaf1dc174f16a8878f20385299aa4d321d431a8d67f474f42cedc99691266d2d SHA512 18bd71f146113b8a892962ab8531f3cb364c05eef4748a9110c4be8fb09b2893cd04330b68ae22f078c4e5328ff9eea0441ea9958e6cc4dbd2471b021c4b15b9
MISC metadata.xml 361 BLAKE2B 64a1d56c1c20595adff59c8df102b6301c8d8eb9ff7c4c2a9e326d0c144d1cbf10a1dd2c61b64eb3ffc757955e689cecbe5c69528d59e9b79007150a9327a74b SHA512 edb195766bc66572ead0b5913a26be82df533cfea7d22d4aadc90c2644c22e458e34f227092a556bc644de35f6e64184b3683ea9015ae6d9126dffe47340d8b0
diff --git a/dev-python/pipx/pipx-1.4.1.ebuild b/dev-python/pipx/pipx-1.4.1.ebuild
index 1b7ee2c493b3..388b94a953f1 100644
--- a/dev-python/pipx/pipx-1.4.1.ebuild
+++ b/dev-python/pipx/pipx-1.4.1.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
+TEST_SHIM=pipx-1.4.1-test-shim
DESCRIPTION="Install and Run Python Applications in Isolated Environments"
HOMEPAGE="
https://pipx.pypa.io/stable/
@@ -18,6 +19,9 @@ HOMEPAGE="
SRC_URI="
https://github.com/pypa/pipx/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_SHIM}.tar.xz
+ )
"
LICENSE="MIT"
@@ -35,14 +39,49 @@ RDEPEND="
"
BDEPEND="
dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ensurepip-pip
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ )
"
-PROPERTIES="test_network"
-RESTRICT="test"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+src_prepare() {
+ if use test; then
+ cp -vs "${BROOT}"/usr/lib/python/ensurepip/{pip,setuptools,wheel}-*.whl \
+ "${WORKDIR}/${TEST_SHIM}/" || die
+ mkdir -p .pipx_tests/package_cache || die
+ local v
+ for v in 3.{10..12}; do
+ ln -s "${WORKDIR}/${TEST_SHIM}" \
+ ".pipx_tests/package_cache/${v}" || die
+ done
+
+ : > scripts/update_package_cache.py || die
+ # sigh
+ sed -e 's:server = str.*:server = "pypi-server":' \
+ -i tests/conftest.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
python_test() {
- epytest --net-pypiserver
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_run.py::test_run_ensure_null_pythonpath
+ tests/test_run.py::test_run_script_from_internet
+ 'tests/test_install.py::test_install_package_specs[pycowsay-git+https://github.com/cs01/pycowsay.git@master]'
+ tests/test_install.py::test_force_install_changes
+ 'tests/test_install.py::test_install_package_specs[nox-https://github.com/wntrblm/nox/archive/2022.1.7.zip]'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -x
}