summaryrefslogtreecommitdiff
path: root/dev-python/pipx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 07:33:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 07:33:01 +0000
commitaa3d072f61e6cd7fc4df214959d003f944fe1619 (patch)
tree7963dc15cd686cf863046c2d8eca4203e66b89b4 /dev-python/pipx
parent65e0298c5630af19b2b181c2dd143bb47aa54231 (diff)
gentoo auto-resync : 30:12:2023 - 07:33:01
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest2
-rw-r--r--dev-python/pipx/pipx-1.4.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
index de7bfb210882..4d22e74a2590 100644
--- a/dev-python/pipx/Manifest
+++ b/dev-python/pipx/Manifest
@@ -1,3 +1,5 @@
DIST pipx-1.3.3.gh.tar.gz 355893 BLAKE2B f2ae8847d4c6f2205fe75a47df04afb49d57cc8f717cc615d5201f54bd2dee2940bc095a778496cd7baf048df8db8e74ca7ff5a7ee3b2024bf37f27bbeb425eb SHA512 42246a0d8275beee16b85a1007d46d328a892beb89e79fb406ba53942a57b7312d34150376835395b9eca3ecb68db71f0c3c470fd92519dd9175311003707a3d
+DIST pipx-1.4.0.gh.tar.gz 357942 BLAKE2B 34b0ede5a5160c8a5fcdff81c4902e0119041e7740b165c3a384234ba8362fa95db8002778a8987b4f93d9bd132152868171bb1627987c4cb7f4eb1cf2e4cc84 SHA512 5a0cd494ed6a4faa3f9f5cc5c56ee8ce9f27b3a456ad2eed2eaf5a9d175ea97209b2ec7b95e1500e1126ec066660f344f942692916cef552c39f49b2669160c9
EBUILD pipx-1.3.3.ebuild 1015 BLAKE2B f485027bfea36ae7437318770b311a066fc733c02e1def5e131cfcc49d54663e7cb08acaef41c44b51d3c48e01595d257b991a1457fb001cd2465ec894557438 SHA512 0ba78cc0064af06a5eb9251307badd83191d0c34db2417ba0e32167ef64e2c564abf489b4e7f0b3de4bf6ac93343862e689092a8d491cefc969c96a018d94716
+EBUILD pipx-1.4.0.ebuild 1015 BLAKE2B f485027bfea36ae7437318770b311a066fc733c02e1def5e131cfcc49d54663e7cb08acaef41c44b51d3c48e01595d257b991a1457fb001cd2465ec894557438 SHA512 0ba78cc0064af06a5eb9251307badd83191d0c34db2417ba0e32167ef64e2c564abf489b4e7f0b3de4bf6ac93343862e689092a8d491cefc969c96a018d94716
MISC metadata.xml 361 BLAKE2B 64a1d56c1c20595adff59c8df102b6301c8d8eb9ff7c4c2a9e326d0c144d1cbf10a1dd2c61b64eb3ffc757955e689cecbe5c69528d59e9b79007150a9327a74b SHA512 edb195766bc66572ead0b5913a26be82df533cfea7d22d4aadc90c2644c22e458e34f227092a556bc644de35f6e64184b3683ea9015ae6d9126dffe47340d8b0
diff --git a/dev-python/pipx/pipx-1.4.0.ebuild b/dev-python/pipx/pipx-1.4.0.ebuild
new file mode 100644
index 000000000000..ff6c65c37339
--- /dev/null
+++ b/dev-python/pipx/pipx-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Install and Run Python Applications in Isolated Environments"
+HOMEPAGE="
+ https://pipx.pypa.io/stable/
+ https://pypi.org/project/pipx/
+ https://github.com/pypa/pipx/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/pypa/pipx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/userpath-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest --net-pypiserver
+}