summaryrefslogtreecommitdiff
path: root/dev-python/pipx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-16 04:41:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-16 04:41:57 +0100
commit668b36c015ae61191cf7d5007b0afdbdcedab441 (patch)
tree2ea72a4f3d3f0cbdf023f218912809157a31ab7d /dev-python/pipx
parent7a0f8a92967dc1c6eab8d6f66ec476905009a287 (diff)
gentoo auto-resync : 16:07:2023 - 04:41:57
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest3
-rw-r--r--dev-python/pipx/metadata.xml12
-rw-r--r--dev-python/pipx/pipx-1.2.0.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
new file mode 100644
index 000000000000..bdebbe3c7757
--- /dev/null
+++ b/dev-python/pipx/Manifest
@@ -0,0 +1,3 @@
+DIST pipx-1.2.0.gh.tar.gz 405655 BLAKE2B 04e796cde0609e6191a18bd835c4aa5faa1e149898a1507dd6ca46f956320f0b45df87c7be13a089510def9f8eb5e8b9a8e45630c186f52a8a39b7316d517e6a SHA512 3563b986ecb80a57dab6a811f3c9d952f50647b530ceacdb4103bcc16f14b53602040b102830354c3b9a3518e095045a6e3bfd8fc5499cf25b6061d30b19cd6c
+EBUILD pipx-1.2.0.ebuild 761 BLAKE2B 77a442dcdd60a2c67703781be480f06322dce9e493361ece2386d2eb65195df26136f55bfca4e636f2bf0cad189ee4ac00fa1bda821cdc7278224f18eec1683d SHA512 0ba7216868328f440187b2e416b1e0da55434696bd38952384ff88e69d1b006dc6ef5472df9ae353212cac5b64e67f968c5cc8b388b0519bda9c8bdd87b02478
+MISC metadata.xml 361 BLAKE2B 64a1d56c1c20595adff59c8df102b6301c8d8eb9ff7c4c2a9e326d0c144d1cbf10a1dd2c61b64eb3ffc757955e689cecbe5c69528d59e9b79007150a9327a74b SHA512 edb195766bc66572ead0b5913a26be82df533cfea7d22d4aadc90c2644c22e458e34f227092a556bc644de35f6e64184b3683ea9015ae6d9126dffe47340d8b0
diff --git a/dev-python/pipx/metadata.xml b/dev-python/pipx/metadata.xml
new file mode 100644
index 000000000000..9d7f8d31d438
--- /dev/null
+++ b/dev-python/pipx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pipx</remote-id>
+ <remote-id type="github">pypa/pipx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pipx/pipx-1.2.0.ebuild b/dev-python/pipx/pipx-1.2.0.ebuild
new file mode 100644
index 000000000000..05620f297c16
--- /dev/null
+++ b/dev-python/pipx/pipx-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Install and Run Python Applications in Isolated Environments"
+HOMEPAGE="
+ https://pypi.org/project/pipx/
+ https://pypa.github.io/pipx/
+"
+# no tests in sdist
+SRC_URI="https://github.com/pypa/pipx/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/userpath-1.6.0[${PYTHON_USEDEP}]
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --net-pypiserver
+}