summaryrefslogtreecommitdiff
path: root/dev-python/pipx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 16:58:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 16:58:27 +0000
commit4c552e09a1ece7792f2a20ccf4322348acbe3139 (patch)
treea0748a931217558c420eaac365cbf63f15eb25c0 /dev-python/pipx
parent4ead5818a5d230bcc875202c487761a9b786e945 (diff)
gentoo auto-resync : 04:12:2023 - 16:58:27
Diffstat (limited to 'dev-python/pipx')
-rw-r--r--dev-python/pipx/Manifest2
-rw-r--r--dev-python/pipx/pipx-1.3.2.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pipx/Manifest b/dev-python/pipx/Manifest
index d3157e121717..40569365e5a5 100644
--- a/dev-python/pipx/Manifest
+++ b/dev-python/pipx/Manifest
@@ -1,5 +1,7 @@
DIST pipx-1.2.1.gh.tar.gz 405585 BLAKE2B ca24ffd9fe3657549d149aa6e24f85ef2d7ae0832f94605a0a52ecd255232c3bd1b553e61be805bd80c9d54586a4e6e9e156db17c5bb901e24069828f0716594 SHA512 93a0d67de9540584987be126d4e28a2628beefba99e15936369c948dc29fb7f11745413ef3f0ace5586b4456ed8554103bcd5079079bc0a34babc02823f7f9d3
DIST pipx-1.3.1.gh.tar.gz 418883 BLAKE2B f9c0ee11eb1e92efb4fc1600d56383ff838b3d97200a4baef32d1221e05c65aeb9d9cc48477dbdf85cb596f44423fb746abd97be2861724ca0de433aa6794d68 SHA512 9ee91efa142f72fbe962d05a21ad3bfcef4d401a20078863bb65a932b3598efff95cd707ec27cca1d4c82f3396270c7162d4cb1407ad1d40b2e477aa0b3c02fc
+DIST pipx-1.3.2.gh.tar.gz 411632 BLAKE2B d7a84a7b23f937e1b00340a7acd76e8d90c54de8955233e6aed8f95aa4b8ee613b1120fbda5a02ffdb63fe11e7efed6e0fdbca7bcb9de42476e78b9af4144b34 SHA512 a0a21c22a867b7bae3d6aceb68e1c5ee404ad794211c7f9014223d510250953b80a5fb525a11a422ae54ee9b0ede81220fa1e145f91b934bf000185a50b613f7
EBUILD pipx-1.2.1.ebuild 761 BLAKE2B 77a442dcdd60a2c67703781be480f06322dce9e493361ece2386d2eb65195df26136f55bfca4e636f2bf0cad189ee4ac00fa1bda821cdc7278224f18eec1683d SHA512 0ba7216868328f440187b2e416b1e0da55434696bd38952384ff88e69d1b006dc6ef5472df9ae353212cac5b64e67f968c5cc8b388b0519bda9c8bdd87b02478
EBUILD pipx-1.3.1.ebuild 887 BLAKE2B 71463764881cded1969281047594f5f9a67f1aa871c483cca356105694b860ede4be999860c0ab389e2e8bedccd39b5634e92f228bc59ac8c761e5be276b5511 SHA512 7a4aaeb88e9ae035e900e10bc08e9fa637652188434f22e4654f21ef56e3e11d3ad73e9fbaac265b92aef6c017584af57d749f7d4c5ca1fd4bedd256c18d2175
+EBUILD pipx-1.3.2.ebuild 984 BLAKE2B 2f5b2e41fee253ea94bc6fe5edea25d55f2d6d7bb6fa6b47b66171419ebf2fbeb192dfd1d3a529826bdcf197221f6a25cad58ec3e003a1c51f5cf5b1eb11f04a SHA512 51728541c740ccf4a948b2a095a9d5b63af31fac593882bb54dfedcd00493ab01adac649800b3ca915ed31fac4eb9e4435227a78445e7a106fa2ce142a656def
MISC metadata.xml 361 BLAKE2B 64a1d56c1c20595adff59c8df102b6301c8d8eb9ff7c4c2a9e326d0c144d1cbf10a1dd2c61b64eb3ffc757955e689cecbe5c69528d59e9b79007150a9327a74b SHA512 edb195766bc66572ead0b5913a26be82df533cfea7d22d4aadc90c2644c22e458e34f227092a556bc644de35f6e64184b3683ea9015ae6d9126dffe47340d8b0
diff --git a/dev-python/pipx/pipx-1.3.2.ebuild b/dev-python/pipx/pipx-1.3.2.ebuild
new file mode 100644
index 000000000000..db8f5d7da26c
--- /dev/null
+++ b/dev-python/pipx/pipx-1.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Install and Run Python Applications in Isolated Environments"
+HOMEPAGE="
+ https://pypi.org/project/pipx/
+ https://pypa.github.io/pipx/
+"
+# no tests in sdist
+SRC_URI="
+ https://github.com/pypa/pipx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/userpath-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest --net-pypiserver
+}