summaryrefslogtreecommitdiff
path: root/dev-python/pipenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pipenv
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest3
-rw-r--r--dev-python/pipenv/files/pipenv-2020.4.1_beta1-disable-networked-tests.patch41
-rw-r--r--dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild46
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 4cc69ab02ef9..105b614cbbba 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,3 +1,6 @@
+AUX pipenv-2020.4.1_beta1-disable-networked-tests.patch 1326 BLAKE2B 35d6850eaff8346016fb8ad2d847466185e92a6cd1879a8bcc8cfed6cfbb97b43ff976b0bb400891287720e2cce3df9cf19472acd5df85d2df6b331046ea01f7 SHA512 1a19a0c19e2cc6bf4c017a17c588a8d3685003a01f2621d9ddf87938935fd76a8f9d8ffd36efc70dbfc3323c739561a67941e10b22f032f4c2020f3ba8cfaf10
DIST pipenv-2018.11.26.tar.gz 6560580 BLAKE2B a3846de696733b5f3f393163999d7f333b52accdcebadfd800507defd1108ac4ccb288b39fb805ecf03e417cfe0d1a8b2fc714a95e8ee4485f8622ff8fe4a1ca SHA512 59582ad4a0730083ea58867f7a5d9714290d62947f56bec80e154d4359fe1dff16e44974a7fba3841e5f2516f2ce9709baf9954c9fc40fd66ebc46c3060d4dea
+DIST pipenv-2020.4.1_beta1.tar.gz 11331009 BLAKE2B 55ac81238b885bdf0293199ca1caf44a78f3cdbec75c9df259411b949dec8b385161e7ef46160ca099ef51041410d8c5d1274ad200eba5c2a9d06c8a5f61c5f1 SHA512 a5de90ae9910a30666ac7323ccf83b78ee11d8993aef1a2108a44f4256d365d0c1abfff72c83748ef82215914931090c670a10eeb511cb48483762b54c80e5c7
EBUILD pipenv-2018.11.26.ebuild 975 BLAKE2B 8fa22f7dd1b7408096ae96ce93051e3b5ddc72438a1e398ef6c7df11447fa7998b633c3df52ba75ce15fb4623aa0f69fdc48c9b5a199429eb56b9dc8a419b6f2 SHA512 55feb0ce1250ca45e4aa63a0a4c88d410f8ac219c1db07f51ad6ccc1279b8c3267d4f2f0cea586539da55bdb7935509ea505da243d1d7dac71ed9715e2138efc
+EBUILD pipenv-2020.4.1_beta1.ebuild 1192 BLAKE2B 65a48723db56713ecdfd3b1f9f2474aded7d188bb3c2ee56353d6a041b1ab132b38d530a5db73eb6c6b3d31358152a83d9542995ef5006725208e0621dd01b9a SHA512 e152dc3cc59d1deef7ef10e8499ac610607e238af6dfd400dbc710f8b23abdffd23995c2adc8d59b22a11fbeaba7ec7e15e31d43791ad0efa78685d14a4cd3d9
MISC metadata.xml 365 BLAKE2B 9be07839eb6a0126b586877cbe691e906850e5310535e7d3ce91bfad2ebcb4c28d9071a6b131d99310b6802ba6ebe026c90d1e94ac3f2f189d775181aea5b997 SHA512 dd94c56de88065dca0d2f49493b25b5fec1d9eb19e3dd8475b4213f6f3af3f7163535430fd6098dca78ba00c2deae2db454774797b4babe3d72ded3a1258cd0a
diff --git a/dev-python/pipenv/files/pipenv-2020.4.1_beta1-disable-networked-tests.patch b/dev-python/pipenv/files/pipenv-2020.4.1_beta1-disable-networked-tests.patch
new file mode 100644
index 000000000000..f3ba4ff6502f
--- /dev/null
+++ b/dev-python/pipenv/files/pipenv-2020.4.1_beta1-disable-networked-tests.patch
@@ -0,0 +1,41 @@
+From 7cf8c7ee7eaba1b5a11562a7ef656b0606383fe8 Mon Sep 17 00:00:00 2001
+From: Oz Tiram <oz.tiram@gmail.com>
+Date: Mon, 4 May 2020 21:52:09 +0000
+Subject: [PATCH] Disable test cases that requires network
+
+---
+ tests/unit/test_utils.py | 11 +----------
+ 1 file changed, 1 insertion(+), 10 deletions(-)
+
+diff --git a/tests/unit/test_utils.py b/tests/unit/test_utils.py
+index 4b9cd75c..1c73964b 100644
+--- a/tests/unit/test_utils.py
++++ b/tests/unit/test_utils.py
+@@ -47,16 +47,6 @@ DEP_PIP_PAIRS = [
+ },
+ "-e svn+svn://svn.myproject.org/svn/MyProject#egg=MyProject",
+ ),
+- (
+- # Extras in url
+- {
+- "discord.py": {
+- "file": "https://github.com/Rapptz/discord.py/archive/async.zip",
+- "extras": ["voice"],
+- }
+- },
+- "https://github.com/Rapptz/discord.py/archive/async.zip#egg=discord.py[voice]",
+- ),
+ (
+ {
+ "requests": {
+@@ -222,6 +212,7 @@ class TestUtils:
+ assert pipenv.utils.is_valid_url(url)
+ assert pipenv.utils.is_valid_url(not_url) is False
+
++ @pytest.mark.skip("Network required. Gentoo tests run in a sendbox without network")
+ @pytest.mark.utils
+ def test_download_file(self):
+ url = "https://github.com/pypa/pipenv/blob/master/README.md"
+--
+2.26.2
+
diff --git a/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild b/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild
new file mode 100644
index 000000000000..8182443641be
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/pip-18.0[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-36.2.1[${PYTHON_USEDEP}]"
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ <dev-python/pytest-5[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2020.4.1_beta1-disable-networked-tests.patch"
+)
+
+python_test() {
+ pytest -m "not cli" -vv tests/unit || die
+}