summaryrefslogtreecommitdiff
path: root/dev-python/pipenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pipenv
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest6
-rw-r--r--dev-python/pipenv/pipenv-2020.11.4.ebuild52
-rw-r--r--dev-python/pipenv/pipenv-2020.8.13.ebuild (renamed from dev-python/pipenv/pipenv-2020.6.2.ebuild)9
3 files changed, 61 insertions, 6 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 7bb44b61d47d..4dea6943a94f 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,3 +1,5 @@
-DIST pipenv-2020.6.2.tar.gz 11571734 BLAKE2B bc50535f215b11d284eeec546722a144cfdfeeab6abab8eae51c727c054865f274ac970dc61c23cce7db19ac28a77e44a84453743ba2dc75068feb3a47a19190 SHA512 671765b9e77a18039668eb500989de45c8bd4f15948ee914eb241985098562ebd382168a535a449ac5d216f07327b6787eb8f828b5a6499ef6e77fe5a036441e
-EBUILD pipenv-2020.6.2.ebuild 1346 BLAKE2B c546dcb33a2b6d51054c9f79473bf4f141ab4d07e78663871baba96811cf93dc9db48793e542cf63932258bb10d180bd42aa6bb28573d9f67486d968d674e0b6 SHA512 4ac51e70b7e9c2ca15c2623b19d46de8c74fb198ceb7d8bb7ccd1ab9dc07ca0ebc5a095a7997888e80ec8569de5a5abd3055d92eb83db0c7683ad04275ee5b45
+DIST pipenv-2020.11.4.tar.gz 11574683 BLAKE2B cb2ac4ba6b07377a3a5540b23756afac38a02691e495ba93031815417d001701b919221fd83d0f9e6b94d4f28c1fa754c2c31e289830305a8c8ac75d847209c4 SHA512 c9015eb9a449fa517f31619d1fec5d99882da915a50e189ba6ab9c7c147862f9734f0df200330d666380afe5d2cf52d18015c539635ca6459042ab50d3ccd059
+DIST pipenv-2020.8.13.tar.gz 11573493 BLAKE2B ac6c6f0336f0c675f73fbecfdefe158eb2a53b5aa4559850b3c9a050404d9d18b0ff2ca3cb62031da027937244a6bbb0d4c1ec433073e429518ec0ea908cb12e SHA512 90ccaf386bc68d856ee9c645084cb65c4213902a8c87e2059cc2274b88d922c3b02c58c15d05945e1f61e8b816ef92a11672cadaf125143bd5019ab25ff0b19e
+EBUILD pipenv-2020.11.4.ebuild 1446 BLAKE2B 904eacf558813bcd4b8b9d9a2dcb6f191b73cea1c015a14005b527702cdfb34d3f7a57da2c79f9bbd7378b0183f2c2328b9f61a2afeebe6f62949a3a15095e2b SHA512 c09d4f2bc93f3e65c1f4fb24e82bbb5a8d13fdfc7625155023fe7fe74c341ef658f6599bdb18b0bed0d42c4ecb17e8c2161aa9e283aa4bf530e4912e73842b37
+EBUILD pipenv-2020.8.13.ebuild 1422 BLAKE2B c8966fb2ddba41cad2fee8fca10d331237a96a2e5a0e0d949cf6f37b0a3689c6ed916628caf229ad3f61cbfc771c6f6a9b80628e32b1cde23c96fd801fdc0c7a SHA512 b4640a87842ffd0b6fc82580437232e943a334380cce4851dbeb50cc51f364b0c828bd3468911cf2b016ac55d89081dbf1df0057046839ff1dc17c30d4dc007b
MISC metadata.xml 587 BLAKE2B 1e496afc6cd4106ead561a0becf969fb53c85b1b874f161e94c4292b4a749ee412333ad3f148d1fd490b71ad5ac23dee363ed8533f72df4444b9928e725a8aa9 SHA512 61da4c2a68ea2727787337ba59a0a1029dec322336c174bbc1697d033ae79f67ea1f3cf694acc18c50d40e5d9807245847d92dc6c9adca1d9b80d23894af9620
diff --git a/dev-python/pipenv/pipenv-2020.11.4.ebuild b/dev-python/pipenv/pipenv-2020.11.4.ebuild
new file mode 100644
index 000000000000..7dbeba42f1dd
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2020.11.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]
+ "
+
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ <dev-python/pytest-5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ # remove vendored version of PyYAML that is backported to Python2
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/patched/yaml2/" || die
+ # disable running of unittests in parallel with xdist
+ sed -i 's/addopts = -ra -n auto/;&/g' setup.cfg || die
+ sed -i 's/plugins = xdist/;&/g' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
+}
diff --git a/dev-python/pipenv/pipenv-2020.6.2.ebuild b/dev-python/pipenv/pipenv-2020.8.13.ebuild
index 49b5811f9f01..d9f0436d554f 100644
--- a/dev-python/pipenv/pipenv-2020.6.2.ebuild
+++ b/dev-python/pipenv/pipenv-2020.8.13.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
@@ -33,8 +33,6 @@ BDEPEND="
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
<dev-python/pytest-5[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
)"
@@ -42,9 +40,12 @@ src_prepare() {
# remove vendored version of PyYAML that is backported to Python2
# this should be removed when upstream removes support for Python2
rm -vR "${S}/${PN}/patched/yaml2/" || die
+ # disable running of unittests in parallel with xdist
+ sed -i 's/addopts = -ra -n auto/;&/g' setup.cfg
+ sed -i 's/plugins = xdist/;&/g' setup.cfg
distutils-r1_src_prepare
}
python_test() {
- pytest -m "not cli and not needs_internet" -vv tests/unit || die
+ pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
}