summaryrefslogtreecommitdiff
path: root/dev-python/pip/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pip/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pip/files')
-rw-r--r--dev-python/pip/files/pip-19.3.1-network-tests.patch66
-rw-r--r--dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch17
-rw-r--r--dev-python/pip/files/pip-20.0.2-disable-system-install.patch16
-rw-r--r--dev-python/pip/files/pip-20.2-no-coverage.patch163
-rw-r--r--dev-python/pip/files/pip-9.0.1-disable-version-check.patch32
-rw-r--r--dev-python/pip/files/pip-disable-system-install.patch29
6 files changed, 171 insertions, 152 deletions
diff --git a/dev-python/pip/files/pip-19.3.1-network-tests.patch b/dev-python/pip/files/pip-19.3.1-network-tests.patch
deleted file mode 100644
index f194a7b34a90..000000000000
--- a/dev-python/pip/files/pip-19.3.1-network-tests.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/news/7359.trivial b/news/7359.trivial
-new file mode 100644
-index 000000000..e69de29bb
-diff --git a/tests/functional/test_freeze.py b/tests/functional/test_freeze.py
-index d13c931d0..2e35de3e6 100644
---- a/tests/functional/test_freeze.py
-+++ b/tests/functional/test_freeze.py
-@@ -721,6 +721,7 @@ def test_freeze_user(script, virtualenv, data):
- assert 'simple2' not in result.stdout
-
-
-+@pytest.mark.network
- def test_freeze_path(tmpdir, script, data):
- """
- Test freeze with --path.
-@@ -734,5 +735,6 @@ def test_freeze_path(tmpdir, script, data):
- _check_output(result.stdout, expected)
-
-
-+@pytest.mark.network
- def test_freeze_path_exclude_user(tmpdir, script, data):
- """
-@@ -756,6 +758,7 @@ def test_freeze_path_exclude_user(tmpdir, script, data):
- _check_output(result.stdout, expected)
-
-
-+@pytest.mark.network
- def test_freeze_path_multiple(tmpdir, script, data):
- """
- Test freeze with multiple --path arguments.
-diff --git a/tests/functional/test_install.py b/tests/functional/test_install.py
-index a9eff081d..ba7a0a55c 100644
---- a/tests/functional/test_install.py
-+++ b/tests/functional/test_install.py
-@@ -1325,6 +1325,7 @@ def test_install_no_binary_disables_building_wheels(script, data, with_wheel):
- assert "Running setup.py install for upper" in str(res), str(res)
-
-
-+@pytest.mark.network
- def test_install_no_binary_builds_pep_517_wheel(script, data, with_wheel):
- to_install = data.packages.joinpath('pep517_setup_and_pyproject')
- res = script.pip(
-diff --git a/tests/functional/test_install_config.py b/tests/functional/test_install_config.py
-index 176976c4e..308263928 100644
---- a/tests/functional/test_install_config.py
-+++ b/tests/functional/test_install_config.py
-@@ -133,6 +133,7 @@ def test_command_line_appends_correctly(script, data):
- ), 'stdout: {}'.format(result.stdout)
-
-
-+@pytest.mark.network
- def test_config_file_override_stack(script, virtualenv):
- """
- Test config files (global, overriding a global config with a
-diff --git a/tests/functional/test_install_upgrade.py b/tests/functional/test_install_upgrade.py
-index 6d2eeb5dc..0024de4d4 100644
---- a/tests/functional/test_install_upgrade.py
-+++ b/tests/functional/test_install_upgrade.py
-@@ -8,6 +8,7 @@
- from tests.lib.local_repos import local_checkout
-
-
-+@pytest.mark.network
- def test_no_upgrade_unless_requested(script):
- """
- No upgrade if not specifically requested.
diff --git a/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch b/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch
deleted file mode 100644
index 8486c37f0c73..000000000000
--- a/dev-python/pip/files/pip-19.3.1-r2-disable-system-install.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
-
---- pip-19.1/src/pip/_internal/commands/install.py
-+++ pip-19.1/src/pip/_internal/commands/install.py
-@@ -246,6 +246,9 @@ class InstallCommand(RequirementCommand):
- if options.upgrade:
- upgrade_strategy = options.upgrade_strategy
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path and not os.getenv('GENTOO_PIP_TESTING'):
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- if options.build_dir:
- options.build_dir = os.path.abspath(options.build_dir)
diff --git a/dev-python/pip/files/pip-20.0.2-disable-system-install.patch b/dev-python/pip/files/pip-20.0.2-disable-system-install.patch
index c6b5354bc68f..e0b0034e407a 100644
--- a/dev-python/pip/files/pip-20.0.2-disable-system-install.patch
+++ b/dev-python/pip/files/pip-20.0.2-disable-system-install.patch
@@ -1,29 +1,29 @@
-From 57d610bbcc721c2e58fd2e9f3197bb3e3acbd935 Mon Sep 17 00:00:00 2001
+From 3aee04cbb93c0e479b040e682b2aef676629c9a2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Sat, 1 Feb 2020 09:14:46 +0100
Subject: [PATCH] install: Raise an error to avoid breaking python-exec
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
+Running pip without --target, --prefix, --root, or --user will result
+in packages being installed systemwide. This has a tendency to break
+python-exec if setuptools gets installed or upgraded.
---
src/pip/_internal/commands/install.py | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/pip/_internal/commands/install.py b/src/pip/_internal/commands/install.py
-index 02a187c8..025b824b 100644
+index 8c2c32fd..41bac878 100644
--- a/src/pip/_internal/commands/install.py
+++ b/src/pip/_internal/commands/install.py
-@@ -246,6 +246,9 @@ class InstallCommand(RequirementCommand):
+@@ -238,6 +238,9 @@ class InstallCommand(RequirementCommand):
if options.upgrade:
upgrade_strategy = options.upgrade_strategy
-+ if not options.use_user_site and not options.target_dir and not options.root_path and not os.getenv('GENTOO_PIP_TESTING'):
++ if not options.use_user_site and not options.target_dir and not options.root_path and not options.prefix_path and not os.getenv('GENTOO_PIP_TESTING'):
+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
+
cmdoptions.check_dist_restriction(options, check_target=True)
install_options = options.install_options or []
--
-2.25.0
+2.28.0
diff --git a/dev-python/pip/files/pip-20.2-no-coverage.patch b/dev-python/pip/files/pip-20.2-no-coverage.patch
new file mode 100644
index 000000000000..55be5b8c9712
--- /dev/null
+++ b/dev-python/pip/files/pip-20.2-no-coverage.patch
@@ -0,0 +1,163 @@
+From 43389903a55a5432ca8556f42fb2252c91c7ca45 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 29 Jul 2020 07:42:25 +0200
+Subject: [PATCH] Revert "Add basic test coverage configuration"
+
+This is just PITA since coverage uses native C extensions.
+---
+ .coveragerc | 4 +++
+ setup.cfg | 38 ----------------------
+ tests/conftest.py | 16 +--------
+ tools/requirements/tests-common_wheels.txt | 2 --
+ tox.ini | 16 ++-------
+ 5 files changed, 7 insertions(+), 69 deletions(-)
+ create mode 100644 .coveragerc
+
+diff --git a/.coveragerc b/.coveragerc
+new file mode 100644
+index 00000000..5f833c94
+--- /dev/null
++++ b/.coveragerc
+@@ -0,0 +1,4 @@
++[run]
++branch = True
++omit =
++ src/pip/_vendor/*
+diff --git a/setup.cfg b/setup.cfg
+index 45fd58a3..e40596e9 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -67,44 +67,6 @@ markers =
+ yaml: yaml based tests
+ fails_on_new_resolver: Does not yet work on the new resolver
+
+-[coverage:run]
+-branch = True
+-# Do not gather coverage for vendored libraries.
+-omit = */_vendor/*
+-# Centralized absolute file prefix for coverage files.
+-data_file = ${COVERAGE_OUTPUT_DIR}/.coverage
+-# By default, each covered process will try to truncate and then write to
+-# `data_file`, but with `parallel`, they will write to separate files suffixed
+-# with hostname, pid, and a timestamp.
+-parallel = True
+-# If not set, then at the termination of each worker (when using pytest-xdist),
+-# the following is traced: "Coverage.py warning: Module pip was previously
+-# imported, but not measured (module-not-measured)"
+-disable_warnings = module-not-measured
+-
+-[coverage:paths]
+-# We intentionally use "source0" here because pytest-cov unconditionally sets
+-# "source" after loading the config.
+-source0 =
+- # The primary source code path which other paths will be combined into.
+- src/pip/
+- # Unit test source directory e.g.
+- # `.tox/coverage-py3/lib/pythonX.Y/site-packages/pip/...`
+- */site-packages/pip/
+- # Functional test virtual environment directories, which look like
+- # `tmpdir/pip0/pip/src/pip/...`
+- */pip/src/pip/
+-
+-[coverage:report]
+-exclude_lines =
+- # We must re-state the default because the `exclude_lines` option overrides
+- # it.
+- pragma: no cover
+- # This excludes typing-specific code, which will be validated by mypy anyway.
+- if MYPY_CHECK_RUNNING
+- # Can be set to exclude e.g. `if PY2:` on Python 3
+- ${PIP_CI_COVERAGE_EXCLUDES}
+-
+ [bdist_wheel]
+ universal = 1
+
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 2aab5020..0db6d967 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -294,13 +294,6 @@ def wheel_install(tmpdir_factory, common_wheels):
+ 'wheel')
+
+
+-@pytest.fixture(scope='session')
+-def coverage_install(tmpdir_factory, common_wheels):
+- return _common_wheel_editable_install(tmpdir_factory,
+- common_wheels,
+- 'coverage')
+-
+-
+ def install_egg_link(venv, project_name, egg_info_dir):
+ with open(venv.site / 'easy-install.pth', 'a') as fp:
+ fp.write(str(egg_info_dir.resolve()) + '\n')
+@@ -310,7 +303,7 @@ def install_egg_link(venv, project_name, egg_info_dir):
+
+ @pytest.fixture(scope='session')
+ def virtualenv_template(request, tmpdir_factory, pip_src,
+- setuptools_install, coverage_install):
++ setuptools_install, common_wheels):
+
+ if six.PY3 and request.config.getoption('--use-venv'):
+ venv_type = 'venv'
+@@ -334,13 +327,6 @@ def virtualenv_template(request, tmpdir_factory, pip_src,
+ subprocess.check_call([venv.bin / 'python', 'setup.py', '-q', 'develop'],
+ cwd=pip_editable)
+
+- # Install coverage and pth file for executing it in any spawned processes
+- # in this virtual environment.
+- install_egg_link(venv, 'coverage', coverage_install)
+- # zz prefix ensures the file is after easy-install.pth.
+- with open(venv.site / 'zz-coverage-helper.pth', 'a') as f:
+- f.write('import coverage; coverage.process_startup()')
+-
+ # Drop (non-relocatable) launchers.
+ for exe in os.listdir(venv.bin):
+ if not (
+diff --git a/tools/requirements/tests-common_wheels.txt b/tools/requirements/tests-common_wheels.txt
+index f0edf0b0..6703d606 100644
+--- a/tools/requirements/tests-common_wheels.txt
++++ b/tools/requirements/tests-common_wheels.txt
+@@ -7,5 +7,3 @@
+
+ setuptools >= 40.8.0
+ wheel
+-# As required by pytest-cov.
+-coverage >= 4.4
+diff --git a/tox.ini b/tox.ini
+index 82e9abc6..7a19ca61 100644
+--- a/tox.ini
++++ b/tox.ini
+@@ -8,7 +8,6 @@ envlist =
+ # Wrapper for calls to pip that make sure the version being used is the
+ # original virtualenv (stable) version, and not the code being tested.
+ pip = python {toxinidir}/tools/tox_pip.py
+-mkdirp = python -c 'import os, sys; os.path.exists(sys.argv[1]) or os.mkdir(sys.argv[1])'
+
+ [testenv]
+ # Remove USERNAME once we drop PY2.
+@@ -31,20 +30,9 @@ commands = pytest --timeout 300 []
+ install_command = {[helpers]pip} install {opts} {packages}
+ list_dependencies_command = {[helpers]pip} freeze --all
+
+-[testenv:coverage]
++[testenv:coverage-py3]
+ basepython = python3
+-commands =
+- {[helpers]mkdirp} {toxinidir}/.coverage-output
+- pytest --timeout 300 --cov=pip --cov-config={toxinidir}/setup.cfg []
+-
+-setenv =
+- # Used in coverage configuration in setup.cfg.
+- COVERAGE_OUTPUT_DIR = {toxinidir}/.coverage-output
+- # Ensure coverage is enabled in child processes in virtual environments
+- # since they won't already have been enabled by pytest-cov.
+- COVERAGE_PROCESS_START = {toxinidir}/setup.cfg
+- # Used in coverage configuration in setup.cfg.
+- PIP_CI_COVERAGE_EXCLUDES = if PY2
++commands = pytest --timeout 300 --cov=pip --cov-report=term-missing --cov-report=xml --cov-report=html tests/unit {posargs}
+
+ [testenv:docs]
+ # Don't skip install here since pip_sphinxext uses pip's internals.
+--
+2.28.0
+
diff --git a/dev-python/pip/files/pip-9.0.1-disable-version-check.patch b/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
deleted file mode 100644
index 7334380c1e1d..000000000000
--- a/dev-python/pip/files/pip-9.0.1-disable-version-check.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 890a1c26018752f2c57c7800968e4b8d1e0987f9 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sun, 20 Nov 2016 19:52:40 +0100
-Subject: [PATCH] Stop checking for new versions
-
----
- pip/basecommand.py | 9 ---------
- 1 file changed, 9 deletions(-)
-
-diff --git a/pip/basecommand.py b/pip/basecommand.py
-index 54c6706..3cffe86 100644
---- a/pip/basecommand.py
-+++ b/pip/basecommand.py
-@@ -241,15 +241,6 @@ class Command(object):
- logger.critical('Exception:', exc_info=True)
-
- return UNKNOWN_ERROR
-- finally:
-- # Check if we're using the latest version of pip available
-- if (not options.disable_pip_version_check and not
-- getattr(options, "no_index", False)):
-- with self._build_session(
-- options,
-- retries=0,
-- timeout=min(5, options.timeout)) as session:
-- pip_version_check(session)
-
- return SUCCESS
-
---
-2.10.2
-
diff --git a/dev-python/pip/files/pip-disable-system-install.patch b/dev-python/pip/files/pip-disable-system-install.patch
deleted file mode 100644
index 9e572454315e..000000000000
--- a/dev-python/pip/files/pip-disable-system-install.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 847553da616edabede18c69ba640a32b719b45a8 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Tue, 27 Oct 2015 12:20:44 -0400
-Subject: [PATCH] install: Raise an error to avoid breaking python-exec
-
-Running pip without --target, --root, or --user will result in packages
-being installed systemwide. This has a tendency to break python-exec if
-setuptools gets installed or upgraded.
----
- pip/commands/install.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/pip/commands/install.py b/pip/commands/install.py
-index 46cd9f2..36b72f2 100644
---- a/pip/commands/install.py
-+++ b/pip/commands/install.py
-@@ -204,6 +204,9 @@ class InstallCommand(RequirementCommand):
- )
- options.ignore_installed = True
-
-+ if not options.use_user_site and not options.target_dir and not options.root_path:
-+ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
-+
- if options.build_dir:
- options.build_dir = os.path.abspath(options.build_dir)
-
---
-2.6.2
-