summaryrefslogtreecommitdiff
path: root/dev-python/pip/files/pip-21.3-no-coverage.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/pip/files/pip-21.3-no-coverage.patch
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/pip/files/pip-21.3-no-coverage.patch')
-rw-r--r--dev-python/pip/files/pip-21.3-no-coverage.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pip/files/pip-21.3-no-coverage.patch b/dev-python/pip/files/pip-21.3-no-coverage.patch
new file mode 100644
index 000000000000..8292f97f9488
--- /dev/null
+++ b/dev-python/pip/files/pip-21.3-no-coverage.patch
@@ -0,0 +1,52 @@
+From 8473691148031ed4db5bd8870fbeef9484b9c831 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 23 Oct 2021 08:11:11 +0200
+Subject: [PATCH] Disable coverage testing support inside test venvs
+
+---
+ tests/conftest.py | 15 ---------------
+ 1 file changed, 15 deletions(-)
+
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 076aeaf19..77c41dc15 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -340,13 +340,6 @@ def wheel_install(tmpdir_factory: pytest.TempdirFactory, common_wheels: Path) ->
+ return _common_wheel_editable_install(tmpdir_factory, common_wheels, "wheel")
+
+
+-@pytest.fixture(scope="session")
+-def coverage_install(
+- tmpdir_factory: pytest.TempdirFactory, common_wheels: Path
+-) -> Path:
+- return _common_wheel_editable_install(tmpdir_factory, common_wheels, "coverage")
+-
+-
+ def install_egg_link(
+ venv: VirtualEnvironment, project_name: str, egg_info_dir: Path
+ ) -> None:
+@@ -362,7 +355,6 @@ def virtualenv_template(
+ tmpdir_factory: pytest.TempdirFactory,
+ pip_src: Path,
+ setuptools_install: Path,
+- coverage_install: Path,
+ ) -> Iterator[VirtualEnvironment]:
+
+ venv_type: VirtualEnvironmentType
+@@ -389,13 +381,6 @@ def virtualenv_template(
+ [venv.bin / "python", "setup.py", "-q", "develop"], cwd=pip_editable
+ )
+
+- # Install coverage and pth file for executing it in any spawned processes
+- # in this virtual environment.
+- install_egg_link(venv, "coverage", coverage_install)
+- # zz prefix ensures the file is after easy-install.pth.
+- with open(venv.site / "zz-coverage-helper.pth", "a") as f:
+- f.write("import coverage; coverage.process_startup()")
+-
+ # Drop (non-relocatable) launchers.
+ for exe in os.listdir(venv.bin):
+ if not (
+--
+2.33.1
+