summaryrefslogtreecommitdiff
path: root/dev-python/pip-run
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pip-run
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest3
-rw-r--r--dev-python/pip-run/metadata.xml13
-rw-r--r--dev-python/pip-run/pip-run-8.8.0.ebuild40
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
new file mode 100644
index 000000000000..f42e8c64aff5
--- /dev/null
+++ b/dev-python/pip-run/Manifest
@@ -0,0 +1,3 @@
+DIST pip-run-8.8.0.gh.tar.gz 22145 BLAKE2B 18b915a29a1767022a609e356005e87f035c3d9bab6dd5ab44f9f42668f4d64c4ee5360cb92b217aa2b7b94e0fbfdb5f0e494e668d9bed8badc38ab36cced353 SHA512 301083a34dea08035819024f17d8108f9751a765cdfc8f2e273b948c7746111efedd80765a63c3ac145bdf7d2b41c9a0b2b20286181c4c94cbc5501fb81eb74d
+EBUILD pip-run-8.8.0.ebuild 881 BLAKE2B 0d659be6459a6b90fe4a1f3f907e7698e66d2da287d4b16596538bb13ab1ab9545d6290493528a8745cc143784389b39073ad0dffbf22edff07ac5631899c1d6 SHA512 22609ccc96fd8186445b4ca52ef580b94ade154e93e1fdfe248bc7b5e117d6fc74a5c4adb48cb50d22620c8fff089a5cb66e1b986aadca228ef5e768289928bb
+MISC metadata.xml 389 BLAKE2B bc573b4f57b4f8371ecef97266b8441d47e66d551f7088a7f312ca049f7debd90e989d24d59d7aff182795ae27e553d131f3875c789dc793532ff9c812bcaf20 SHA512 00b81cba684e7118a3ce79ec5cb6a27d6ad67064a2745ffead8dec51c7786c9441139b800868cad8854ff39d7e38163ab2c8fa5c7d3f328390b628f8342fb0ca
diff --git a/dev-python/pip-run/metadata.xml b/dev-python/pip-run/metadata.xml
new file mode 100644
index 000000000000..00337c32ff89
--- /dev/null
+++ b/dev-python/pip-run/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pip-run</remote-id>
+ <remote-id type="github">jaraco/pip-run</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pip-run/pip-run-8.8.0.ebuild b/dev-python/pip-run/pip-run-8.8.0.ebuild
new file mode 100644
index 000000000000..accd1c717974
--- /dev/null
+++ b/dev-python/pip-run/pip-run-8.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="https://pypi.org/project/pip-run/
+ https://github.com/jaraco/pip-run"
+SRC_URI="
+ https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Needs network access, and another test dep nbformat
+ pip_run/tests/test_scripts.py
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}