summaryrefslogtreecommitdiff
path: root/dev-python/pip-run
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
commitb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (patch)
tree4fcc91b967ba153d4030d61e10f1b07b53755488 /dev-python/pip-run
parent2d3042634af4767714cb90eff3f773ef54afb5ed (diff)
gentoo auto-resync : 29:05:2023 - 09:16:49
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest2
-rw-r--r--dev-python/pip-run/pip-run-10.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 2fb278233366..fdb0b341001e 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,5 +1,7 @@
DIST pip-run-10.0.7.tar.gz 32869 BLAKE2B ea5dfea09def536eced9436a114f12cbefccf26c4b37376a560dc1fffdd8167d019ec52d57666d7b4d77dc9c580a5f48455d945aa9ddb4340a7dca88f0ded309 SHA512 cd8780372f579005e40c77b3c2d9e582cd1a144e871eec205fd0bd2ff64eac837918211d3479088f56bd3043dbfd883502b2d6f7b01dc24448888f65fdd6920b
DIST pip-run-10.1.1.tar.gz 33010 BLAKE2B 5a3dcd1e119b65718b465ecbd118d80de776252ecbd438344eb78abc2e4a69073417310ed096f0b604740762aa24af2788041476c93d919ea72812e1597327f5 SHA512 ddf61aa31012567ff21e943739a1e29066875db3c39ca77abfa409fd75abc599756ca8aeaf9bd23d19af46ad2747e7dec4a7d3cf76a444f59c19e769419dc59a
+DIST pip-run-10.2.0.tar.gz 33523 BLAKE2B 7d19c089da98dbba2faec969f490fcd5ea48881f4ccbbfaa283465ef083521aee7d82b9de8b03a89ec8b08005db1232cd9577030cb98c111b4a0e0f7294cca84 SHA512 b26a00c6ebd8e9e505e6b218fea7070b23b5926de44e1d5a762abb2a4ebd62b1bdda7e19c4092012daf068b518a2e127ab08099f6d1a7ddc643b3ba5bf999ed0
EBUILD pip-run-10.0.7.ebuild 1415 BLAKE2B 37eddbbd484c549b5a3c5274c0f4fe29c093c0c555c43e47a00de0127c4196f49c39e157a588e08c5b1a6ae6f19cbf206e47e67aa70a7718519a01d382ed3105 SHA512 0ba95169ac46a7649f8bce7ee8d5cc81e6cdcfc2c77f014a6692e1f2717351cfaf2bd529bde083ebc59853b452d8749ac36034768ef980ac6e2d1a307a3fd4a5
EBUILD pip-run-10.1.1.ebuild 1510 BLAKE2B dc758aac78a5f9fac5c5572ca113dd766793222b4da1ea31ae38a24824c4007401c9c02088d57955061abd2b556b1742038ab960dc0e0494262bfae31ef80401 SHA512 1940163e757ddeb9b3122ef227e771f108eb25629768c58e245fbd446afb8293020e4a796426c9c9cc9b2571510ce71f631a8b5bd3db0c964c680a448607bac8
+EBUILD pip-run-10.2.0.ebuild 1510 BLAKE2B dc758aac78a5f9fac5c5572ca113dd766793222b4da1ea31ae38a24824c4007401c9c02088d57955061abd2b556b1742038ab960dc0e0494262bfae31ef80401 SHA512 1940163e757ddeb9b3122ef227e771f108eb25629768c58e245fbd446afb8293020e4a796426c9c9cc9b2571510ce71f631a8b5bd3db0c964c680a448607bac8
MISC metadata.xml 389 BLAKE2B bc573b4f57b4f8371ecef97266b8441d47e66d551f7088a7f312ca049f7debd90e989d24d59d7aff182795ae27e553d131f3875c789dc793532ff9c812bcaf20 SHA512 00b81cba684e7118a3ce79ec5cb6a27d6ad67064a2745ffead8dec51c7786c9441139b800868cad8854ff39d7e38163ab2c8fa5c7d3f328390b628f8342fb0ca
diff --git a/dev-python/pip-run/pip-run-10.2.0.ebuild b/dev-python/pip-run/pip-run-10.2.0.ebuild
new file mode 100644
index 000000000000..36f03616bed3
--- /dev/null
+++ b/dev-python/pip-run/pip-run-10.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib-resources[${PYTHON_USEDEP}]
+ ' 3.8)
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_scripts.py
+ )
+ fi
+
+ epytest -m "not network"
+}