summaryrefslogtreecommitdiff
path: root/dev-python/pip-run
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /dev-python/pip-run
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest2
-rw-r--r--dev-python/pip-run/pip-run-9.2.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index ceee0a8e06a9..8f1b2a864669 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1,3 +1,5 @@
DIST pip-run-9.0.0.gh.tar.gz 23171 BLAKE2B ca1bee27f4d1826029aa2520dbad9807d22ce66326fd917f0b7687284ce3daf9abcd45e593d735633fb86186ea88ffa0b71780f9b56e27458798763db309bd9d SHA512 117b2260fe628dcc5aae47335ab645c2db47ca9b4d5cd0446ef11bb399c0e91df3a32b61aa7a228aca4d7b837228ddb41fe010896f7debf5fbca6111398cce73
+DIST pip-run-9.2.1.gh.tar.gz 24104 BLAKE2B ebb26cd5356a5919d74c6601b36deed0046c0d67d7533f5817b62b7b7ba74240ef44dd2425be7143f8432d3f8a3f611a051f099b6059e64479eadd77e8f39b45 SHA512 f320da7641817df5c9418094fb49792e3368907ddac551ef22d97ab45b5183cb84f40338da106d5a47d238ca68ca376cbfc6d6c3528b9fca1db02bf910bd3d28
EBUILD pip-run-9.0.0.ebuild 963 BLAKE2B e176a68ad10beab276e7150bd917d9d3dd5507e8000932e6afae6bc662838af36d5f377b9515208b12e4464eb5fbc2c137c1f1531e3891eb616d7f96c4b9c56a SHA512 7f72c4b7def3b9b29fa49dffe2accb678a696f9742846e2a812908f1bba2039867a003f45f005d2f61a1c7604c1f100ff447601a05e5718b8651454737f87191
+EBUILD pip-run-9.2.1.ebuild 1144 BLAKE2B f521960057405acc8f2ed3e52b051e90da48a3655d344776956602ef749543289eb30879acf63fdfd8065cc1edd6ff00ff908bfc3731ff7733f47d7e9dcf11fd SHA512 5822639fa79991d6a9b09ab296e94dbbb5d1f31f75ee3c4de74a141603ee9ff542f5ad9229b71fc9711abb088ac5b982987d3a62fe0178bb5bd4242cb8dce8a7
MISC metadata.xml 389 BLAKE2B bc573b4f57b4f8371ecef97266b8441d47e66d551f7088a7f312ca049f7debd90e989d24d59d7aff182795ae27e553d131f3875c789dc793532ff9c812bcaf20 SHA512 00b81cba684e7118a3ce79ec5cb6a27d6ad67064a2745ffead8dec51c7786c9441139b800868cad8854ff39d7e38163ab2c8fa5c7d3f328390b628f8342fb0ca
diff --git a/dev-python/pip-run/pip-run-9.2.1.ebuild b/dev-python/pip-run/pip-run-9.2.1.ebuild
new file mode 100644
index 000000000000..c6cb50c96746
--- /dev/null
+++ b/dev-python/pip-run/pip-run-9.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+SRC_URI="
+ https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Needs network access, and another test dep nbformat
+ tests/test_scripts.py
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}