summaryrefslogtreecommitdiff
path: root/dev-python/pip-run/pip-run-10.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-python/pip-run/pip-run-10.2.0.ebuild
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-python/pip-run/pip-run-10.2.0.ebuild')
-rw-r--r--dev-python/pip-run/pip-run-10.2.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pip-run/pip-run-10.2.0.ebuild b/dev-python/pip-run/pip-run-10.2.0.ebuild
deleted file mode 100644
index 9b0cb9ba3a7a..000000000000
--- a/dev-python/pip-run/pip-run-10.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Install packages and run Python with them"
-HOMEPAGE="
- https://github.com/jaraco/pip-run/
- https://pypi.org/project/pip-run/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/autocommand[${PYTHON_USEDEP}]
- dev-python/jaraco-context[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/path[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jaraco-path[${PYTHON_USEDEP}]
- >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/nbformat[${PYTHON_USEDEP}]
- ' python3_{10..11})
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=()
-
- if ! has_version "dev-python/nbformat[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/test_scripts.py
- )
- fi
-
- epytest -m "not network"
-}