summaryrefslogtreecommitdiff
path: root/dev-python/pillow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pillow
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest2
-rw-r--r--dev-python/pillow/pillow-8.1.2.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 571797ba631f..a7c8a9dae3bf 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,3 +1,5 @@
DIST pillow-8.1.1.tar.gz 44976395 BLAKE2B 208534f3e24d9416360efaab8f802b4d482208fe81d1b39bf8339ddd1fe992b281a59faaadeb5ad5364ff062b1b7b19c3dadc11f9a453d5bd14bbf5170521396 SHA512 d04300442ac33e946bea186d6293516b615059b0f4b1b6ac7a48ce3a2e4e22bce5bc403331be697c022a4c81cb30f943cc33bfda649873c734af7db23afd6b69
+DIST pillow-8.1.2.tar.gz 45217041 BLAKE2B dbc7fb5c426c6a8f0efd218db5cd404c6b6a603054b36125ea687c69cca78ddd2e58712e8fe94460978bffe6bc059e5819d7ac6371bad11ee8fc1df445495c70 SHA512 32ffedf8cc8f2c21c241f41938d0521626ea05206d1a762305ac38abedecdf9bc8a6e5e2ded7565340e54797a4395acefb3b4d939ebdde8fc9583a1998bae34d
EBUILD pillow-8.1.1.ebuild 2621 BLAKE2B a0df80c884d2ae46c5f02126e220dbb10330c35e25ccc8a24ba4ce451efe93aac0ce1f2ce753cccc286626a3841a46a683ef4c15435175e0caa6a46f7ee86e6a SHA512 3337dd0acc4a11306870d428a64e7af65f381d57ada6fe44ebdbd748eeef28b69d7081c6485fe93b38e93f33da734d7d398a91fd4b8e9e273624d4a687464fb7
+EBUILD pillow-8.1.2.ebuild 2629 BLAKE2B fe83d3ef84696b841bda4c81ecb331d2187ab00778246ef67942138e22267dbbea3eaafe8718520f3072c6157483dc52653a2716d8e723301b0467f963d31eea SHA512 665272d523162f76719895e3a3a0ba82736834e2675f96236968b702eba765456c0252c70eb06f825b16e72db847f750acd6b37c8ed0ba8f4e31a9e29d01d8a8
MISC metadata.xml 479 BLAKE2B 8573c3f71b8e0d548f50dcb630a7c36d773ca8bb80f210bec320dc85bf12b70e9f30068dea615925c401726f0a5430827baa0104300abfd85060b522065c8d37 SHA512 473a9aea70516087faba8abddcd02bb76cb62711a5446fc5c58cedc0f0beb70cdef32e928ec293698b524d2e49440be2328567f84efeea4333477b7b9bd7a7d2
diff --git a/dev-python/pillow/pillow-8.1.2.ebuild b/dev-python/pillow/pillow-8.1.2.ebuild
new file mode 100644
index 000000000000..65a55a7139fe
--- /dev/null
+++ b/dev-python/pillow/pillow-8.1.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg jpeg2k tiff )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:0 )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:0= )"
+RDEPEND="${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[png]
+ )
+"
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
+ --disable-platform-guessing
+ $(use_enable truetype freetype)
+ $(use_enable jpeg)
+ $(use_enable jpeg2k jpeg2000)
+ $(use_enable lcms)
+ $(use_enable tiff)
+ $(use_enable imagequant)
+ $(use_enable webp)
+ $(use_enable webp webpmux)
+ $(use_enable xcb)
+ $(use_enable zlib)
+ )
+
+ # setup.py sucks at adding the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but this setup.py does stupid things.
+ export \
+ INCLUDE=${ESYSROOT}/usr/include \
+ LIB=${ESYSROOT}/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}