summaryrefslogtreecommitdiff
path: root/dev-python/pilkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pilkit
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pilkit')
-rw-r--r--dev-python/pilkit/Manifest2
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild14
2 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/pilkit/Manifest b/dev-python/pilkit/Manifest
index a83ed7d09628..528b8aa2c1a0 100644
--- a/dev-python/pilkit/Manifest
+++ b/dev-python/pilkit/Manifest
@@ -1,3 +1,3 @@
DIST pilkit-2.0.tar.gz 160077 BLAKE2B def84c3444c5ffe7e1b9c016c2fe15de222d6765e7ce4652ef2f6864af59fdc89b9bde5c7a63097838ab3fc054c81529dcb4a13cd3fb3ee8a0f141f6b0030c10 SHA512 7732c67bc00db53c6849c907233381cca7f9055d55d479958a7b97db277524ac280753fd40c0023fe2b34f98b7261134f993585e658275ccd4c67f357c13de51
-EBUILD pilkit-2.0.ebuild 697 BLAKE2B 2f7a6f467eca12ee5eb38cfd0257fa9d4e841150e049eba2ad3b54488f22d0777cb75d35d29d697492454ac6bab0383724377517a25e1ee4f942c94afc3b9f53 SHA512 840242159340af774d1067827c72eda2de8e6bd6a06c84ef03c38bf1f99c2c6ad2797cd6826b97465ff09d0bfd228274e0a613c1f44206d1cd553ddb8212fb8c
+EBUILD pilkit-2.0.ebuild 658 BLAKE2B 3cb204688de57db486416d22a74bccb8f1bd454635517bd6aa2bc6d24defa3102d6a34114e9bbefadd85dcefc9812bb46cf42aef2a910db8bce4731320a034a0 SHA512 dc34641aff1425888745c48cf946f1e8f418eab8fa8d810e2c0d1f22add2ac4b5dd349ac8f5c3a793dd80df93461ceb01410c79bfcad33cb53524135d3d11509
MISC metadata.xml 577 BLAKE2B e7c419d819dbafed2aa0ce7b470f370ec17db804c479b5bc031f0d14f9650ed188eff40c1b428e3a3362a7e340dd7d5e1a6306068d70bdd56b6aa6f0796bb2a0 SHA512 cce0def750ad671b397d8a8827944f64f235009862f472aa8a70c7c0a240ba3cda7f65de0c9f0c6c138a9e7cf236cff65f5a1cc417465e8eb3b1c4d4dc7b5d01
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
index dd16f29d4fb2..6ef202af3c2c 100644
--- a/dev-python/pilkit/pilkit-2.0.ebuild
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -13,17 +13,13 @@ SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},jpeg,zlib]
)"
-RDEPEND="${CDEPEND}"
-python_test() {
- nosetests --verbose || die
-}
+distutils_enable_tests nose