summaryrefslogtreecommitdiff
path: root/dev-python/pilkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /dev-python/pilkit
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'dev-python/pilkit')
-rw-r--r--dev-python/pilkit/Manifest3
-rw-r--r--dev-python/pilkit/metadata.xml23
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild28
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pilkit/Manifest b/dev-python/pilkit/Manifest
new file mode 100644
index 000000000000..fda63e5b1317
--- /dev/null
+++ b/dev-python/pilkit/Manifest
@@ -0,0 +1,3 @@
+DIST pilkit-2.0.tar.gz 160077 SHA256 01a1c3b920f4a0f73d4f0ddd252031eba78697c7af8ba5f94e43c8b2fc7a07cf SHA512 7732c67bc00db53c6849c907233381cca7f9055d55d479958a7b97db277524ac280753fd40c0023fe2b34f98b7261134f993585e658275ccd4c67f357c13de51 WHIRLPOOL a99362e2bbdab5c96e8d39a367f98a9cd7947cca18e68a3b903f2a5cc9b5279fdf4fd1f489073e594823def31e4e2dc02c256e4834a7bc4e889550a9cc978f8c
+EBUILD pilkit-2.0.ebuild 681 SHA256 9d85748bcea1ad381cd0f13c924fac26a70c8a4e5ec62bb9d19989435b571a2f SHA512 cac22400b70066fca9f0160781ac62254604d48d9b36b2f71df093eeed9364110cce2c475288c1d70a3430f3f14bae87c7b0fc7a851eb99f0d7daa67b12fe96b WHIRLPOOL 7a97c0b97f38722c8672ba6d784466d1989e7c6e891df6601ec78fc9b76b5496e5a87fd34c5fec4dbb4abb9f5dbc63cd3d64fab6f17b59e132f494b92e6efdab
+MISC metadata.xml 707 SHA256 8d419365a0cd0d00a3a7f57cf4fe1073165190a20d67054caddefd0f76c1778b SHA512 32ae881094153b9179401cc55abc4a03469d9004b121afad62bdcbe80725c687f5779fcb3e2286c051f6038e98f7838d89308f12fba4c0fb15e5abe6e27df556 WHIRLPOOL 04810feb2dfc83882a8b61feedb87cc9468c649edeb6aee4f03a9b204b842fd25c3ee5b8d1ab469f85df7a49b53031a748914d20367f85372c1138739523faa7
diff --git a/dev-python/pilkit/metadata.xml b/dev-python/pilkit/metadata.xml
new file mode 100644
index 000000000000..b4d5770a92d6
--- /dev/null
+++ b/dev-python/pilkit/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thomas@gstaedtner.net</email>
+ <name>Thomas Gstädtner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pilkit</remote-id>
+ <remote-id type="github">matthewwithanm/pilkit</remote-id>
+ <bugs-to>
+ https://github.com/matthewwithanm/pilkit/issues
+ </bugs-to>
+ </upstream>
+ <longdescription>
+ PILKit is a collection of utilities for working with
+ PIL (the Python Imaging Library).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
new file mode 100644
index 000000000000..b55d51a92e54
--- /dev/null
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities and processors for the Python Imaging Libary"
+HOMEPAGE="https://github.com/matthewwithanm/pilkit"
+SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests --verbose || die
+}