summaryrefslogtreecommitdiff
path: root/dev-python/piexif
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/piexif
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/piexif')
-rw-r--r--dev-python/piexif/Manifest3
-rw-r--r--dev-python/piexif/metadata.xml7
-rw-r--r--dev-python/piexif/piexif-1.0.12.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
new file mode 100644
index 000000000000..a4025eb7b338
--- /dev/null
+++ b/dev-python/piexif/Manifest
@@ -0,0 +1,3 @@
+DIST piexif-1.0.12.zip 1005725 SHA256 312e01e2113d0885088cf43704d8c7337fdb0144789a59b05ebaf7b24e6ebb95 SHA512 71de13b30d041c2de2136e9299bea96a0446352815de5358863324743aac6a5e187800214edd209dd212108ce9a0b0b4602aee54dd54f8b058228b255b543c63 WHIRLPOOL 6adc52a4551e55b70338fbba6c350864353bdaa55a10f225d3fde086f5232c4a9725a94db04695fd87b46662a91dba253aa3ccfa342b700a2e2974c0792affcb
+EBUILD piexif-1.0.12.ebuild 567 SHA256 e39d579bce6a82f150f9ac12bfab15c0d9275b58070dc91fda6e32f4fd55b2ac SHA512 79c318b9d1233d26fd2c75622578ba04e21e654e522f4dbb2ba2200c9879aeb60f03f1e567a77754ef16bc0f2d7d22b3fec87315d7828e41753e7c5b3e529e27 WHIRLPOOL b0eb4bd351e06caeb316388d06b5bd8b3b21f6e1cf55fb2464f6b6ee002ba9f4a3a41917e4eb5c3bdc35e75fb79ce64392d1ea60c82c09749c807b8fcde49b3e
+MISC metadata.xml 216 SHA256 31f776a176c082debc988ddf52bdb7105b90e07f6fcad657f6fa21bde377aff8 SHA512 1de1c9f4b223876125a0321126f2d7b1b564a113d24ae86b380c4d67bdf58ed4f2ae1a1f5d686211ccf4851eea8e970c20109977abbc79d0cd855164b6474e23 WHIRLPOOL 1a6bba154e326af8b8e97789169b18cd09a434b1dd7193d33e53913966be459db5c622bb1662b19c5f15ea9898e286fef44ce52d7e259f11048894aac15f0b55
diff --git a/dev-python/piexif/metadata.xml b/dev-python/piexif/metadata.xml
new file mode 100644
index 000000000000..82b7b7953794
--- /dev/null
+++ b/dev-python/piexif/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/piexif/piexif-1.0.12.ebuild b/dev-python/piexif/piexif-1.0.12.ebuild
new file mode 100644
index 000000000000..a78227b94958
--- /dev/null
+++ b/dev-python/piexif/piexif-1.0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.python.org/pypi/piexif"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}