summaryrefslogtreecommitdiff
path: root/dev-python/piexif
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
commit325837835fc86686829aaa6acace3d3c06c74cea (patch)
tree6cc31680e4ce26ab26e863fd7b72d0ffe2d9366f /dev-python/piexif
parent7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (diff)
gentoo auto-resync : 08:10:2024 - 04:26:34
Diffstat (limited to 'dev-python/piexif')
-rw-r--r--dev-python/piexif/Manifest1
-rw-r--r--dev-python/piexif/piexif-1.1.3-r3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
index 8fcaae6f8258..7e5d23af531f 100644
--- a/dev-python/piexif/Manifest
+++ b/dev-python/piexif/Manifest
@@ -1,4 +1,5 @@
AUX piexif-1.1.3-tests-pillow-7.2.0.patch 1382 BLAKE2B c7ea03ffe0708b975d64602910bf9c228f0093d9cb717a1b1b9f3e7b6358b94f3bcbd6da8f9bac12fe2ee0745d17defccd196bdd8ec018fea50b7d131e148616 SHA512 be1ee541e3bb6c219d6fd9ab68e9143c2131f695a2001d36a0d63b0566d71a542a09d58dc0bcbdb8c1353297156ea7853d483b9a44407cb31c30acc4252310bf
DIST piexif-1.1.3.zip 1011134 BLAKE2B b27d4419cf545f6205b13c5646dff9fc7b1ce6e5de538f6a7189e6cadb54d301e11cbf0feaed8b073cbf16de95d67c621b68657b35fc0ba2025281ee64be4e51 SHA512 df5f7793c39911af58bbae76cf998e2a7bc820b84dcf9808ee8f6a38f766f824fef28392ef88387e18b10c270c4b27881be310f0368076b6fb65379a11a93270
EBUILD piexif-1.1.3-r2.ebuild 809 BLAKE2B 53f3a8f1f33d78f884ce939997c3b138ced25a919725d5e23fb38cb20bcd950423a677cbc914440a210e12f94ebdfc9c9c18362babcbc7c603da68f764206276 SHA512 6b6ff834e7051421c642accac8b459dc7b4adebb8510792830b24c67fdaeb79ae93ae1d0503d53845ac95ec3a89f571d9b3e6bb009df77b0ca225f9eab5459f2
+EBUILD piexif-1.1.3-r3.ebuild 807 BLAKE2B 4e807ca622f9edd41016efd3b12186d9ae5bdd35a3ca8d8dbc0340d3182b81638a0d73fb13fa8e19796532ab4948a8137c3116c468385875ed8c1ad7e861cc98 SHA512 0422c8f9f8cfe54df8608706a8ef6784e6e2782c1d6ef98c00c0842110cbcd118b8fe53a21b2a8b2c36dbda99413c0c78196c374caa276f4780bea34eb55ae98
MISC metadata.xml 364 BLAKE2B 2ef968ac973776979f74c1ff510b657d691d7cfd1b963b04faed752e4dedfea8f325357b95ea9abede883a8ead27016bd2b657be119902fa21f9bef6ea2ebb0c SHA512 c62c0ee0303599f10b04701183db691da926fb3176f5ad5efcf58782c50280e03dcf5772ab1d033d3dc96730a2ad87c19ce9749a9c0ce2dd3dfdde76d2466eb7
diff --git a/dev-python/piexif/piexif-1.1.3-r3.ebuild b/dev-python/piexif/piexif-1.1.3-r3.ebuild
new file mode 100644
index 000000000000..e904aa79f2cd
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit edos2unix distutils-r1 pypi
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="
+ https://github.com/hMatoba/Piexif/
+ https://pypi.org/project/piexif/
+"
+SRC_URI="$(pypi_sdist_url "${PN}" "${PV}" .zip)"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest
+
+BDEPEND="
+ app-arch/unzip
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ # From https://github.com/hMatoba/Piexif/pull/109
+ "${FILESDIR}"/${P}-tests-pillow-7.2.0.patch
+)
+
+src_prepare() {
+ edos2unix tests/s_test.py # to be able to patch it
+ default
+}