summaryrefslogtreecommitdiff
path: root/dev-python/piexif
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /dev-python/piexif
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'dev-python/piexif')
-rw-r--r--dev-python/piexif/Manifest2
-rw-r--r--dev-python/piexif/piexif-1.1.3-r2.ebuild18
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/piexif/Manifest b/dev-python/piexif/Manifest
index 8491f19a793f..571b825044d5 100644
--- a/dev-python/piexif/Manifest
+++ b/dev-python/piexif/Manifest
@@ -1,4 +1,4 @@
AUX piexif-1.1.3-tests-pillow-7.2.0.patch 1382 BLAKE2B c7ea03ffe0708b975d64602910bf9c228f0093d9cb717a1b1b9f3e7b6358b94f3bcbd6da8f9bac12fe2ee0745d17defccd196bdd8ec018fea50b7d131e148616 SHA512 be1ee541e3bb6c219d6fd9ab68e9143c2131f695a2001d36a0d63b0566d71a542a09d58dc0bcbdb8c1353297156ea7853d483b9a44407cb31c30acc4252310bf
DIST piexif-1.1.3.zip 1011134 BLAKE2B b27d4419cf545f6205b13c5646dff9fc7b1ce6e5de538f6a7189e6cadb54d301e11cbf0feaed8b073cbf16de95d67c621b68657b35fc0ba2025281ee64be4e51 SHA512 df5f7793c39911af58bbae76cf998e2a7bc820b84dcf9808ee8f6a38f766f824fef28392ef88387e18b10c270c4b27881be310f0368076b6fb65379a11a93270
-EBUILD piexif-1.1.3-r2.ebuild 859 BLAKE2B 6ef1f6ca3b0b23b80dc812b33c8439196df195a672897df666f9896e57499ac0dc58766dc8150310f6dbbdd4315daf8d5b71a250071d57f6f5f9e41052ec2a47 SHA512 94828d8b3eecab774bb8fc1c2893ba0b26d1aecf449c7ee281db3c24546ea6eb1dfd444adc8f12a49c3b0730cb1bdfc2dcdd842fae1ecba07699130abef4a666
+EBUILD piexif-1.1.3-r2.ebuild 802 BLAKE2B ef84c96214084ea16ecf7789d8b0bce550fb9dc6397d18cae89d8ddccf78f007dc455d149caa3ed98b4f6cd2dee486e12fa600358786c37ca72890be8ff12382 SHA512 b9437271f0ee04d132f8c5a355843bc912c7c06b4707841692e9208bb02e06ffc4d16f785015e581b41767e514ff714e6f7338be9c6fd8ced1ba926ce3d71c24
MISC metadata.xml 364 BLAKE2B 2ef968ac973776979f74c1ff510b657d691d7cfd1b963b04faed752e4dedfea8f325357b95ea9abede883a8ead27016bd2b657be119902fa21f9bef6ea2ebb0c SHA512 c62c0ee0303599f10b04701183db691da926fb3176f5ad5efcf58782c50280e03dcf5772ab1d033d3dc96730a2ad87c19ce9749a9c0ce2dd3dfdde76d2466eb7
diff --git a/dev-python/piexif/piexif-1.1.3-r2.ebuild b/dev-python/piexif/piexif-1.1.3-r2.ebuild
index 86b91124fcd9..5afdf1943a90 100644
--- a/dev-python/piexif/piexif-1.1.3-r2.ebuild
+++ b/dev-python/piexif/piexif-1.1.3-r2.ebuild
@@ -6,12 +6,14 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit edos2unix distutils-r1
+inherit edos2unix distutils-r1 pypi
DESCRIPTION="Exif manipulation with pure Python"
-HOMEPAGE="https://github.com/hMatoba/Piexif
- https://pypi.org/project/piexif/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+HOMEPAGE="
+ https://github.com/hMatoba/Piexif/
+ https://pypi.org/project/piexif/
+"
+SRC_URI="$(pypi_sdist_url "${PN}" "${PV}" .zip)"
LICENSE="MIT"
SLOT="0"
@@ -19,10 +21,10 @@ KEYWORDS="amd64 ~riscv ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
app-arch/unzip
- test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )"
-RDEPEND=""
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )
+"
PATCHES=(
# From https://github.com/hMatoba/Piexif/pull/109
@@ -35,5 +37,5 @@ src_prepare() {
}
python_test() {
- "${PYTHON}" setup.py test || die
+ esetup.py test
}