summaryrefslogtreecommitdiff
path: root/dev-python/piexif/piexif-1.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 01:18:33 +0000
commit56767705335e747c2a8b3f3282e5c1a393352d54 (patch)
treedb29fcdff8c7ce293aa55e7ba797c1242cd601c0 /dev-python/piexif/piexif-1.1.3-r2.ebuild
parentee2ff072f141c81ba073dc664091d2780d4e74e0 (diff)
gentoo auto-resync : 29:11:2022 - 01:18:33
Diffstat (limited to 'dev-python/piexif/piexif-1.1.3-r2.ebuild')
-rw-r--r--dev-python/piexif/piexif-1.1.3-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.1.3-r2.ebuild b/dev-python/piexif/piexif-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..44ecb4c39ee1
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit edos2unix distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+ # From https://github.com/hMatoba/Piexif/pull/109
+ "${FILESDIR}"/${P}-tests-pillow-7.2.0.patch
+)
+
+src_prepare() {
+ edos2unix tests/s_test.py # to be able to patch it
+ default
+}
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}