summaryrefslogtreecommitdiff
path: root/dev-python/piexif/piexif-1.0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/piexif/piexif-1.0.13.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/piexif/piexif-1.0.13.ebuild')
-rw-r--r--dev-python/piexif/piexif-1.0.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.0.13.ebuild b/dev-python/piexif/piexif-1.0.13.ebuild
new file mode 100644
index 000000000000..36b6a197b6b7
--- /dev/null
+++ b/dev-python/piexif/piexif-1.0.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}