summaryrefslogtreecommitdiff
path: root/dev-python/pid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pid')
-rw-r--r--dev-python/pid/Manifest5
-rw-r--r--dev-python/pid/metadata.xml17
-rw-r--r--dev-python/pid/pid-2.1.1.ebuild22
-rw-r--r--dev-python/pid/pid-2.2.0.ebuild30
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pid/Manifest b/dev-python/pid/Manifest
new file mode 100644
index 000000000000..66cc67c74508
--- /dev/null
+++ b/dev-python/pid/Manifest
@@ -0,0 +1,5 @@
+DIST pid-2.1.1.tar.gz 9591 BLAKE2B 90bebcd225d96283c771b29d864ab35311e748978040e3667a13fa14d84e9f9f1bfe86a25c93bd4781c80938dc20cf14894f32de87a3c1cbef5797e168e71f0d SHA512 5f20338ca902d68a0c4a614b0b8229cd498712bf1750b68fa49037e9e6915c66ad562564d70d7c9308538f4302e90473a5d253dd6366bfa561f6a2248b21a45e
+DIST pid-2.2.0.tar.gz 10752 BLAKE2B 943626f9eccecb16f3da03d222cf44aae93179d4f97f922dca431960dbd744fb996239332b7e8557464aaf0797505645634ee3a23b88f0e98fb0a9d60f20e7c3 SHA512 bd35110fe67d916265985eeceed08d70a2e2e04507eaadf62bf6c67927fc6b36ca6eaf2a225947f5b0ad049e54eb2371c8576672c0ec3f819208cf6e11543fcc
+EBUILD pid-2.1.1.ebuild 493 BLAKE2B d9b6a54a0dbdd28630f7138c72ec610c938a17311498a90451e86c17064b4e1d94b52284b13d5b2723682bae44c97b161dfaf5634665c5ee933e48ef6267faa3 SHA512 6476ea0d125bbf6f88d7b91871725a1c51d32ceb49bf8c1595cfc3b57e94646e648b0a09c56ffeb2c70005370abba8217d5ee6c8b18e47ea73955e1c67667fc9
+EBUILD pid-2.2.0.ebuild 722 BLAKE2B 86f00bf40951c3749af2232558c747c9cfc5cc8906667788b6af8ebe0eb961619bce76f6e152ef728d4958eb891053381e53216306a4c86947d82f09b58dca50 SHA512 d0f082915f6d70cde7765241f1660430d1320d15a03ff854c4d1bc57cf69b551e7262b091f2f40049704ac2dbcd031f36c714f6db5d4a240ff20dd5c4a75efd2
+MISC metadata.xml 560 BLAKE2B 5af715f7414da897d42890da7399e0eb94a6a9e565168490a30fe6869ea5377cd7c58dfbc1b130f2998752ba0fd2ff0dae9f98479ab22909dcc2b61f9c1abeb3 SHA512 3ca1077fa0948e659fe7673dd885ba306512f75b3706314919de74910482b99c112f4e1cdf2ada3ceff9ebf18bc72dfb46c263ce4da396e1400a6402757c2dcd
diff --git a/dev-python/pid/metadata.xml b/dev-python/pid/metadata.xml
new file mode 100644
index 000000000000..4e998d163a95
--- /dev/null
+++ b/dev-python/pid/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pid</remote-id>
+ <remote-id type="github">trbs/pid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pid/pid-2.1.1.ebuild b/dev-python/pid/pid-2.1.1.ebuild
new file mode 100644
index 000000000000..0f1bc39f4bec
--- /dev/null
+++ b/dev-python/pid/pid-2.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.org/project/pid/ https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/pid/pid-2.2.0.ebuild b/dev-python/pid/pid-2.2.0.ebuild
new file mode 100644
index 000000000000..31548e434889
--- /dev/null
+++ b/dev-python/pid/pid-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.org/project/pid/ https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64"
+IUSE="test"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v --with-coverage --cover-package=pid || die
+}