summaryrefslogtreecommitdiff
path: root/dev-python/pid/pid-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pid/pid-3.0.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pid/pid-3.0.4.ebuild')
-rw-r--r--dev-python/pid/pid-3.0.4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pid/pid-3.0.4.ebuild b/dev-python/pid/pid-3.0.4.ebuild
new file mode 100644
index 000000000000..ad484405ebbd
--- /dev/null
+++ b/dev-python/pid/pid-3.0.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.org/project/pid/ https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest