summaryrefslogtreecommitdiff
path: root/dev-python/phply/phply-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/phply/phply-1.2.5.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/phply/phply-1.2.5.ebuild')
-rw-r--r--dev-python/phply/phply-1.2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/phply/phply-1.2.5.ebuild b/dev-python/phply/phply-1.2.5.ebuild
new file mode 100644
index 000000000000..eddb961c4385
--- /dev/null
+++ b/dev-python/phply/phply-1.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lexer and parser for PHP source implemented using PLY"
+HOMEPAGE="
+ https://github.com/viraptor/phply/
+ https://pypi.org/project/phply/"
+SRC_URI="
+ https://github.com/viraptor/phply/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # namespace? seriously?
+ sed -i -e '/namespace_packages/d' setup.py || die
+ # prevent installing tests, turn phply back into normal package
+ mv tests/__init__.py phply/ || die
+ distutils-r1_src_prepare
+}