summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /dev-python/pgspecial
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest2
-rw-r--r--dev-python/pgspecial/pgspecial-2.0.1.ebuild55
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 7e021d5ad9e0..d0ec7501bf7f 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,5 +1,3 @@
-DIST pgspecial-2.0.1.gh.tar.gz 50181 BLAKE2B 6f3f9f8feba717c18d3985d80a432eb7d127c65f7436bfc792a44cb5d7aad08e6e3b931cc289a051fbfea43cd5d8d7db44ede6de89683d462d51635c5caf2e04 SHA512 e89e7cd0f7e849fe93b8e8e79e409ee73ba6c22f3d76279415f236184f732d12cdd8b6bb7722b24ec2bd665f3429c0bf4e6905cd24c9739aa78906b12f841f13
DIST pgspecial-2.1.0.tar.gz 50495 BLAKE2B 981f5a01ef32090eae7d477d23476fd8dd2a5bd3a5f3781e990cdbd28ebb24e5176653b7c8f9a1b7f1f01888a5c8278568257a709a5337f8b0d9838bfba8a21a SHA512 5bbd53d21ad89698b6ca04c989aa1ed59f3b8adc9b876b5b7db35bca03b964f645df2af96d3ddf6e7718c8ee06953fcf8f3ca548e65d722eaf4ea0098fa126ad
-EBUILD pgspecial-2.0.1.ebuild 1220 BLAKE2B 4fb5388e34e5c7acb4ab8d6bad9160fc918286654849116d8e4bc0d3fb2d02d681ce1ed2ccde01ac9f9b56cf725d2216c2b9920a6478de1e3804aa03f792caf4 SHA512 f2014ddebe6d32346c8ec4d4641d7fbd13b2cb15bd23346adf24082963bf4e6985a544abf43121a34f9e19e66d603050466b0a1c7f463c9ea15b1adeccee5f5c
EBUILD pgspecial-2.1.0.ebuild 1275 BLAKE2B c27111818e4b468796f7b56b609316337137d8b3c81c838a3cf9a12450c4e06cc28c6b2fdd13507024cc3fe2853bb3ba409f71591e70a0862f111528dfff183e SHA512 12749c1301145798ba2429685ec2a1c7e3e99ede09230534e60c2e8c999ed8d97f37b69f73a5f93402eaca25d3cd0db57ecea46d0ed44fbcaa6e15b45f09125b
MISC metadata.xml 542 BLAKE2B f7c36257d672854f57623ce68e09e17b8bc734e0a2afa70308ff3c3dfee23274750a8d98034527e14c757546eb78b84f170b9a4d180e02cf491301ae34127c79 SHA512 cb1eac0516db3ff5f32efb6adcf2c39e5479f7bb2a44f3d7c75f4e38e07812db21fd8e8af94e97c613b54606c2660317b5dbb0221c88cc926968404898f19602
diff --git a/dev-python/pgspecial/pgspecial-2.0.1.ebuild b/dev-python/pgspecial/pgspecial-2.0.1.ebuild
deleted file mode 100644
index d2105974bbd4..000000000000
--- a/dev-python/pgspecial/pgspecial-2.0.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of PostgreSQL meta commands"
-HOMEPAGE="
- https://github.com/dbcli/pgspecial/
- https://pypi.org/project/pgspecial/
-"
-SRC_URI="
- https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( License.txt README.rst changelog.rst )
-
-src_test() {
- local db=${T}/pgsql
-
- initdb --username=postgres -D "${db}" || die
- # TODO: random port
- pg_ctl -w -D "${db}" start \
- -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
- psql -h "${T}" -U postgres -d postgres \
- -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
- createdb -h "${T}" -U postgres _test_db || die
-
- distutils-r1_src_test
-
- pg_ctl -w -D "${db}" stop || die
-}