summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
commitc952bf4dc186a298c5ef1596e2c52642072db500 (patch)
tree0b0b9cc4cdda7b2f9d62548ba883329cf6c15274 /dev-python/pgspecial
parent97c0860d9b4db72365710e1b8ed20644d6f5e926 (diff)
gentoo auto-resync : 01:04:2023 - 11:14:56
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest2
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index de03478d990d..c59040c3f34d 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,3 +1,5 @@
DIST pgspecial-2.0.1.gh.tar.gz 50181 BLAKE2B 6f3f9f8feba717c18d3985d80a432eb7d127c65f7436bfc792a44cb5d7aad08e6e3b931cc289a051fbfea43cd5d8d7db44ede6de89683d462d51635c5caf2e04 SHA512 e89e7cd0f7e849fe93b8e8e79e409ee73ba6c22f3d76279415f236184f732d12cdd8b6bb7722b24ec2bd665f3429c0bf4e6905cd24c9739aa78906b12f841f13
+DIST pgspecial-2.1.0.tar.gz 50495 BLAKE2B 981f5a01ef32090eae7d477d23476fd8dd2a5bd3a5f3781e990cdbd28ebb24e5176653b7c8f9a1b7f1f01888a5c8278568257a709a5337f8b0d9838bfba8a21a SHA512 5bbd53d21ad89698b6ca04c989aa1ed59f3b8adc9b876b5b7db35bca03b964f645df2af96d3ddf6e7718c8ee06953fcf8f3ca548e65d722eaf4ea0098fa126ad
EBUILD pgspecial-2.0.1.ebuild 1220 BLAKE2B 4fb5388e34e5c7acb4ab8d6bad9160fc918286654849116d8e4bc0d3fb2d02d681ce1ed2ccde01ac9f9b56cf725d2216c2b9920a6478de1e3804aa03f792caf4 SHA512 f2014ddebe6d32346c8ec4d4641d7fbd13b2cb15bd23346adf24082963bf4e6985a544abf43121a34f9e19e66d603050466b0a1c7f463c9ea15b1adeccee5f5c
+EBUILD pgspecial-2.1.0.ebuild 1277 BLAKE2B 607f95f866ed0ab7305f52677db5341247344c047b8bb6d7f582c454bb6edeb14de105b655bbe3b2a29198564ba4b24580da08b73f38eefb9adbdde3a6af8641 SHA512 b323e895bc6289412a2fa1173a6539f17771e7887159cf477bfcd22e43bb45dc65c2aa7cd9322267e69841917f8317a35d3f83e3fd7338dfdbb25b7c59f0800c
MISC metadata.xml 542 BLAKE2B f7c36257d672854f57623ce68e09e17b8bc734e0a2afa70308ff3c3dfee23274750a8d98034527e14c757546eb78b84f170b9a4d180e02cf491301ae34127c79 SHA512 cb1eac0516db3ff5f32efb6adcf2c39e5479f7bb2a44f3d7c75f4e38e07812db21fd8e8af94e97c613b54606c2660317b5dbb0221c88cc926968404898f19602
diff --git a/dev-python/pgspecial/pgspecial-2.1.0.ebuild b/dev-python/pgspecial/pgspecial-2.1.0.ebuild
new file mode 100644
index 000000000000..3f8eac9c4b2d
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-2.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="
+ https://github.com/dbcli/pgspecial/
+ https://pypi.org/project/pgspecial/
+"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( License.txt README.rst changelog.rst )
+
+EPYTEST_DESELECT=(
+ # assumes a very specific locale
+ tests/test_specials.py::test_slash_l
+ tests/test_specials.py::test_slash_l_pattern
+)
+
+src_test() {
+ local db=${T}/pgsql
+
+ initdb --username=postgres -D "${db}" || die
+ # TODO: random port
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U postgres -d postgres \
+ -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U postgres _test_db || die
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}