summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pgspecial
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest4
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.7.ebuild33
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.9.ebuild24
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 6e9624df1c56..162bf2c8265f 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,3 +1,7 @@
DIST pgspecial-1.11.5.tar.gz 43649 BLAKE2B f9b8956cfcd81bba946e0323d584668c82e6fc18a0aa08012c3236636d0ad801f10f786b71707daadafc1274d5733adecf9233871b13bded8fe8e8f41fad0fc9 SHA512 984a09a10a705d91d9b97142eb2502b44b2a79d95cc1ed8596dd2f7f31515028f4c34cc54383d762a73fdefd6e59418f677b020181740b82cebb5d8e77bbc234
+DIST pgspecial-1.11.7.tar.gz 44874 BLAKE2B 2d3afd7983a31347a4b0f59fd095684c2fb83e85def027f633734a672c3df1ed21584e2620932efacbdc27a579ea35e810e727456191e02811c81e906373ac5b SHA512 dbcfe996cb67af292c90bec431d918c3e78aa4fb90fcbfc9d5ef36ed0c5c7de58505704df277b586990efcc7110e1395af1476003aafaf359257f0665e4d9a19
+DIST pgspecial-1.11.9.tar.gz 45009 BLAKE2B 3ae53d4225d448c3291d6701caf7388023d140678461a5811673c7cc7ed242fb0c18ea38427210366f58f1886894def348051469c23aff20be7abc5e5c96622f SHA512 b07083ed715a6ac3d1b32ac954b83852fcb154f4b2757fae91ce7c35524576fa8caef5cb7201d313eac783bc956ea89c9d68f099a11c332486d677dfb185caca
EBUILD pgspecial-1.11.5.ebuild 841 BLAKE2B 6e307bf10368f73fccb8581b4f71187a729d982c5823204eb49588f5694f237b2761e68242db1c815b43a4c72e42bab01f730b7716362f127a30fe65a1ce326b SHA512 5158f7d875fe0bcc768ed053b9a2ae9f8f01159442e2163b4546e23c9d7bb7b63e97adaf124d346c87020c8e43a405ea811862063368c5546565a3a8cd502be4
+EBUILD pgspecial-1.11.7.ebuild 800 BLAKE2B 6a6072a773f8fc3f9aad875681d08f251e81d308366f3798566b38eea2856ae60e67b841107f075007657bfb6086aa2095db34a1eeac1f9bfae3c27c3a769cdd SHA512 a2221dede6eb1923e2b946b0b2c6da3ef1f8763c34d3d71d048cc7a39d5c51c7cc991661c00754995bec814fa2ef22fd5c940147f471142b3695a0576de326f7
+EBUILD pgspecial-1.11.9.ebuild 601 BLAKE2B 65d2831a6d4c57e00c51ce35ba3eb879596096483acd539434b74cba6d13d8c21d6820122534c86158163c08617f7bd30aace1dbc6ba48eb037ebe6e41c0c6f5 SHA512 73db6706697bc5977d45f3c7b00e8049c8c7e1819241af554d326a314e28b47f696d8998fe358b5acd3a7fd712dfa17b5e21950dfcb71c307eb39d6cb9429c43
MISC metadata.xml 467 BLAKE2B 4a1fe580d03eee97746d0b3f25ae0f33a693c5095fffbc30e41edb78b5cf48d4e8d39e1bdd6764956ba675c282548993878455177bb766d9f5bb333630925c25 SHA512 fa46dbfa82bd12f191d99d189a2286da31cbc42346df1072b3f445bcc1a79575a8adf17ad79cafd0a5a4a17fc7094a7f3d2e5fac642b2ad61ce84a2299a13f60
diff --git a/dev-python/pgspecial/pgspecial-1.11.7.ebuild b/dev-python/pgspecial/pgspecial-1.11.7.ebuild
new file mode 100644
index 000000000000..06f5ead2917f
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of postgres meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # tests/test_special.py require local postgres instance
+ pytest -vv tests/test_internal.py || die
+}
diff --git a/dev-python/pgspecial/pgspecial-1.11.9.ebuild b/dev-python/pgspecial/pgspecial-1.11.9.ebuild
new file mode 100644
index 000000000000..274f62b7a91d
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of postgres meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest