summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pgspecial
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest2
-rw-r--r--dev-python/pgspecial/pgspecial-1.13.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index d8dbc5f5f28b..17c3cdefb4b9 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,3 +1,5 @@
DIST pgspecial-1.13.0.tar.gz 49204 BLAKE2B 7269fc94fc0672db1880ba4b76c8926b6a3c995aac3fca77add7ae6756fcc3295d8d32fcede37cd3fa2d82c82aebfc26d91ed50b4294c5206f04d4c72742b45b SHA512 de2560106fbad14f2095ace468c8490cb325aedb772f649f20a0b5fe65f19afeed33f219d3a6eca683a63b418741a9906a01f7c4bdd8734868517faeba791026
+DIST pgspecial-1.13.1.tar.gz 50269 BLAKE2B 0566a7c2d8ee1ea350e27a4283f56c4cb1360f23ac9fe0147358ff68f527907c47650466dd41ae9c68e8a1f8ba658e452a88db360a7066f5562b7f0c578b8b62 SHA512 4b8f0495451db40087327640edc4bf8c29997b4f501dc5af6d093ad880fc337050d651676ae8ff434da3564e773f9e89e6e7d6bf0d6cfb7b70d8b4beea73a347
EBUILD pgspecial-1.13.0.ebuild 1130 BLAKE2B 35f50cc7ab0847fa12ada8bbc81ef3963b30a87160a65909d056bd5a0c512b624124b050286c66af22faee4d451278f91bdba9bf815710bebd8de47824662c77 SHA512 799072a2f06afe329faf208c224255a63956d3caf220a0e2c3f537575ebeaac28c3baf5c7b7a93e9515252201000685fbcf166c50e7588249f75eefb56ddcb5b
+EBUILD pgspecial-1.13.1.ebuild 1167 BLAKE2B fbb0d393b16006eccd8df87ecb4bb8a494dff9ca77eaee474f2f051ca9bbc91ba662de444a65c34802f1080b2f4ad039eaef0349e933a1f5a440279a8cf95c7e SHA512 1a0c3d0fba6806fb4026975147bd7dba79372e68ce4d984c6af9c5477af9fc914951e28fcc7f5e541926f28dce3778c7e7ad911bd27291140e91aa289a9c3178
MISC metadata.xml 469 BLAKE2B 4ac30bc0e9dcd93b61f08a2195303556758feb8c6cf2ce083d320d9d2fdd5297a7dc641a18b23bcbc9168dfdbc8b73e682d1b54232b875a8707073e0ea24403b SHA512 42c4588416412787dbaf3ff40bb11aca400b0afcd32ef686495dfd5fde91313a3308e3d49549e196f10d04869f0612a0987a4de4492366494403f1e55998713f
diff --git a/dev-python/pgspecial/pgspecial-1.13.1.ebuild b/dev-python/pgspecial/pgspecial-1.13.1.ebuild
new file mode 100644
index 000000000000..6b76fd83565d
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( >=dev-db/postgresql-8.1[server] )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( License.txt README.rst changelog.rst )
+
+src_test() {
+ local db=${T}/pgsql
+
+ initdb --username=postgres -D "${db}" || die
+ # TODO: random port
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U postgres -d postgres \
+ -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U postgres _test_db || die
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}